summaryrefslogtreecommitdiff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2017-06-25 17:10:55 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2017-06-29 18:09:42 +0200
commit9ae3fcb9e873172b2accc2ed874eb05828db458d (patch)
treec0ef2b476ffb3585241294de56a70aae96af3e30 /gnu/packages/mes.scm
parentc0f5eee4b2cc737be222c4ba331d0c6373d565eb (diff)
downloadguix-patches-9ae3fcb9e873172b2accc2ed874eb05828db458d.tar
guix-patches-9ae3fcb9e873172b2accc2ed874eb05828db458d.tar.gz
gnu: Add mescc-tools.
* gnu/packages/mes.scm (mescc-tools): New variable.
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 3203486268..f85f230c73 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -100,3 +100,32 @@ consists of a mutual self-hosting [close to Guile-] Scheme interpreter
prototype in C and a Nyacc-based C compiler in [Guile] Scheme.")
(home-page "https://gitlab.com/janneke/mes")
(license gpl3+))))
+
+(define-public mescc-tools
+ (package
+ (name "mescc-tools")
+ (version "0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/oriansj/MESCC_Tools/archive/Release_"
+ version
+ ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lzi9sqv41269isn7in70q2hhh087n4v97zr5i2qzz69j2lkr3xb"))))
+ (build-system gnu-build-system)
+ (supported-systems '("i686-linux" "x86_64-linux"))
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:test-target "test"
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (synopsis "Tools for the full source bootstrapping process")
+ (description
+ "Mescc-tools is a collection of tools for use in a full source
+bootstrapping process. Currently consists of the M0 macro assembler and the
+hex2 linker.")
+ (home-page "https://github.com/oriansj/MESCC_Tools")
+ (license gpl3+)))