summaryrefslogtreecommitdiff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
commit57df83e07d4b5e78d9a54c1a88d05b4a9ed65714 (patch)
tree76684e63965e9ad6e37d9d45bc3159e6c9782cd0 /gnu/packages/mes.scm
parent43d9ed7792808638eabb43aa6133f1d6186c520b (diff)
parent136b7d81f0eb713783e9ea7cf7f260a2b6252dfd (diff)
downloadguix-patches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar
guix-patches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm74
1 files changed, 38 insertions, 36 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 9aff59ab1d..c2430f5ee9 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -59,46 +59,48 @@ extensive examples, including parsers for the Javascript and C99 languages.")
(license (list gpl3+ lgpl3+))))
(define-public mes
- (let ((triplet "i686-unknown-linux-gnu"))
- (package
- (name "mes")
- (version "0.19")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/mes/"
- "mes-" version ".tar.gz"))
- (sha256
- (base32
- "15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
- (build-system gnu-build-system)
- (supported-systems '("i686-linux" "x86_64-linux"))
- (propagated-inputs
- `(("mescc-tools" ,mescc-tools)
- ("nyacc" ,nyacc)))
- (native-inputs
- `(("guile" ,guile-2.2)
- ,@(if (not (string-prefix? "i686-linux" (or (%current-target-system)
- (%current-system))))
- ;; Use cross-compiler rather than #:system "i686-linux" to get
- ;; MesCC 64 bit .go files installed ready for use with Guile.
- `(("i686-linux-binutils" ,(cross-binutils triplet))
- ("i686-linux-gcc" ,(cross-gcc triplet)))
- '())
- ("graphviz" ,graphviz)
- ("help2man" ,help2man)
- ("perl" ,perl) ; build-aux/gitlog-to-changelog
- ("texinfo" ,texinfo)))
- (arguments
- `(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
- (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
- (description
- "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
+ (package
+ (name "mes")
+ (version "0.19")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/mes/"
+ "mes-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
+ (build-system gnu-build-system)
+ (supported-systems '("i686-linux" "x86_64-linux"))
+ (propagated-inputs
+ `(("mescc-tools" ,mescc-tools)
+ ("nyacc" ,nyacc)))
+ (native-inputs
+ `(("guile" ,guile-2.2)
+ ,@(let ((target-system (or (%current-target-system)
+ (%current-system))))
+ (cond
+ ((string-prefix? "x86_64-linux" target-system)
+ ;; Use cross-compiler rather than #:system "i686-linux" to get
+ ;; MesCC 64 bit .go files installed ready for use with Guile.
+ `(("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
+ ("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))))
+ (else
+ '())))
+ ("graphviz" ,graphviz)
+ ("help2man" ,help2man)
+ ("perl" ,perl) ; build-aux/gitlog-to-changelog
+ ("texinfo" ,texinfo)))
+ (arguments
+ `(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
+ (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
+ (description
+ "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
bootstrap to Guix and aims to help create full source bootstrapping for
GNU/Linux distributions. It consists of a mutual self-hosting Scheme
interpreter in C and a Nyacc-based C compiler in Scheme and is compatible with
Guile.")
- (home-page "https://gnu.org/software/mes")
- (license gpl3+))))
+ (home-page "https://gnu.org/software/mes")
+ (license gpl3+)))
(define-public mescc-tools
(let ((commit "bb062b0da7bf2724ca40f9002b121579898d4ef7")