summaryrefslogtreecommitdiff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-25 23:21:09 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-26 13:24:28 +0200
commit5510e1c483128bd4be6f1446b7bcfb5252b219c2 (patch)
treea6ba4b0303df2a0ba9fb1a7516be8e1b9eb4efc1 /gnu/packages/mes.scm
parent81096caf7d122485f09226cdd8b2a117a39be4d9 (diff)
downloadguix-patches-5510e1c483128bd4be6f1446b7bcfb5252b219c2.tar
guix-patches-5510e1c483128bd4be6f1446b7bcfb5252b219c2.tar.gz
gnu: mes: Remove 0.19.
* gnu/packages/mes.scm (mes-0.19): Remove. (mes): Copy missing fields from MES-0.19.
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm47
1 files changed, 16 insertions, 31 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index d9d41c8138..412930faed 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -150,21 +150,19 @@ parsers to allow execution with Guile as extension languages.")))
"065ksalfllbdrzl12dz9d9dcxrv97wqxblslngsc6kajvnvlyvpk"))))
(inputs (list guile-3.0))))
-(define-public mes-0.19
- ;; Mes used for bootstrap.
+(define-public mes
(package
(name "mes")
- (version "0.19")
+ (version "0.23")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/mes/"
"mes-" version ".tar.gz"))
(sha256
(base32
- "15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
- (build-system gnu-build-system)
- (supported-systems '("i686-linux" "x86_64-linux"))
- (propagated-inputs (list mescc-tools nyacc-0.86))
+ "0mnryfkl0dwbr5gxp16j5s95gw7z1vm1fqa1pxabp0aiar1hw53s"))))
+ (supported-systems '("armhf-linux" "i686-linux" "x86_64-linux"))
+ (propagated-inputs (list mescc-tools nyacc-1.00.2))
(native-inputs
`(("guile" ,guile-3.0)
,@(let ((target-system (or (%current-target-system)
@@ -181,31 +179,9 @@ parsers to allow execution with Guile as extension languages.")))
("help2man" ,help2man)
("perl" ,perl) ; build-aux/gitlog-to-changelog
("texinfo" ,texinfo)))
+ (build-system gnu-build-system)
(arguments
`(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
- (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
- (description
- "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
-bootstrap to Guix and aims to help create full source bootstrapping for
-GNU/Linux distributions. It consists of a mutual self-hosting Scheme
-interpreter in C and a Nyacc-based C compiler in Scheme and is compatible with
-Guile.")
- (home-page "https://www.gnu.org/software/mes/")
- (license gpl3+)))
-
-(define-public mes
- (package
- (inherit mes-0.19)
- (version "0.23")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/mes/"
- "mes-" version ".tar.gz"))
- (sha256
- (base32
- "0mnryfkl0dwbr5gxp16j5s95gw7z1vm1fqa1pxabp0aiar1hw53s"))))
- (supported-systems '("armhf-linux" "i686-linux" "x86_64-linux"))
- (propagated-inputs (list mescc-tools nyacc-1.00.2))
(native-search-paths
(list (search-path-specification
(variable "C_INCLUDE_PATH")
@@ -216,7 +192,16 @@ Guile.")
(search-path-specification
(variable "MES_PREFIX")
(separator #f)
- (files '("")))))))
+ (files '("")))))
+ (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
+ (description
+ "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
+bootstrap to Guix and aims to help create full source bootstrapping for
+GNU/Linux distributions. It consists of a mutual self-hosting Scheme
+interpreter in C and a Nyacc-based C compiler in Scheme and is compatible with
+Guile.")
+ (home-page "https://www.gnu.org/software/mes/")
+ (license gpl3+)))
(define-public mes-rb5
;; This is the Reproducible-Builds summit 5's Mes, also built on Debian