summaryrefslogtreecommitdiff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2017-05-14 11:35:05 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-14 15:49:50 +0200
commit4be014128e1c422f37b56f9a6b3420b4e85c4302 (patch)
treeca9b2cf88ce703e74bcee3683838049c377ae830 /gnu/packages/mes.scm
parentc65d05b5ac6da768ffae1038f02a810f79dca83c (diff)
downloadguix-patches-4be014128e1c422f37b56f9a6b3420b4e85c4302.tar
guix-patches-4be014128e1c422f37b56f9a6b3420b4e85c4302.tar.gz
gnu: Add Nyacc.
* gnu/packages/mes.scm (nyacc): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index aaa00f78a6..84d6f8ff78 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -26,10 +26,33 @@
#:use-module (gnu packages package-management)
#:use-module (gnu packages perl)
#:use-module (guix build-system gnu)
+ #:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix licenses)
#:use-module (guix packages))
+(define-public nyacc
+ (package
+ (name "nyacc")
+ (version "0.78.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/nyacc/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xrnl2hl9rpl50n8cihvclcd951zj640fj5kpi3d6ihwcqjcdi0a"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("guile" ,guile-2.2)))
+ (synopsis "LALR(1) Parser Generator in Guile")
+ (description
+ "NYACC is an LALR(1) parser generator implemented in Guile.
+The syntax and nomenclature should be considered not stable. It comes with
+extensive examples, including parsers for the Javascript and C99 languages.")
+ (home-page "https://savannah.nongnu.org/projects/nyacc")
+ (license (list gpl3+ lgpl3+))))
+
(define-public mes
(let ((commit "a437c173b9da1949ad966fd50dd4f26e522a910a")
(revision "0")