summaryrefslogtreecommitdiff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-20 15:49:32 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-11 00:49:14 +0200
commit2f73ea3487b3bf6eb055c08aae7c53713d61a4d7 (patch)
treeac11ba849599df0f89fc70796e491f2a869dd408 /gnu/packages/mes.scm
parent04b2f3dd80aa4a138e93a6a4a209c1beac5fca88 (diff)
downloadguix-patches-2f73ea3487b3bf6eb055c08aae7c53713d61a4d7.tar
guix-patches-2f73ea3487b3bf6eb055c08aae7c53713d61a4d7.tar.gz
gnu: Change inputs of core packages to plain lists.
This is transparent: the resulting derivations are unchanged. * gnu/packages/base.scm (grep, sed, tar, patch, diffutils, glibc/hurd-headers) (coreutils, gnu-make, make-glibc-utf8-locales): Change input fields to plain package lists and use 'modify-inputs'. * gnu/packages/guile.scm (guile-1.8, guile-json-1, guile-json-3) (guile-gdbm-ffi, guile-sqlite3, guile-bytestructures) (guile-git, guile-zlib, guile-lzlib, guile-zstd, guile-next): Likewise. * gnu/packages/mes.scm (nyacc-0.86, nyacc-0.99) (nyacc, nyacc-1.00.2, mes-0.19, mes, m2-planet): Likewise.
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm25
1 files changed, 8 insertions, 17 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 2defb45ff1..ab41fc7055 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -56,8 +56,7 @@
(base32
"0lkd9lyspvhxlfs0496gsllwinh62jk9wij6gpadvx9gwz6yavd9"))))
(build-system gnu-build-system)
- (native-inputs
- `(("guile" ,guile-2.2)))
+ (native-inputs (list guile-2.2))
(synopsis "LALR(1) Parser Generator in Guile")
(description
"NYACC is an LALR(1) parser generator implemented in Guile.
@@ -92,10 +91,8 @@ extensive examples, including parsers for the Javascript and C99 languages.")
(("^DOCDIR =.*")
"DOCDIR = @prefix@/share/doc/$(PACKAGE_TARNAME)\n"))
#t))))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("guile" ,guile-2.2)))))
+ (native-inputs (list pkg-config))
+ (inputs (list guile-2.2))))
(define-public nyacc
(package
@@ -116,8 +113,7 @@ extensive examples, including parsers for the Javascript and C99 languages.")
"GUILE_GLOBAL_SITE=\
$prefix/share/guile/site/$GUILE_EFFECTIVE_VERSION\n"))
#t))))
- (inputs
- `(("guile" ,guile-3.0)))))
+ (inputs (list guile-3.0))))
(define-public nyacc-1.00.2
(package
@@ -145,8 +141,7 @@ $prefix/share/guile/site/$GUILE_EFFECTIVE_VERSION\n"))
(sha256
(base32
"065ksalfllbdrzl12dz9d9dcxrv97wqxblslngsc6kajvnvlyvpk"))))
- (inputs
- `(("guile" ,guile-2.2)))))
+ (inputs (list guile-2.2))))
(define-public mes-0.19
;; Mes used for bootstrap.
@@ -162,9 +157,7 @@ $prefix/share/guile/site/$GUILE_EFFECTIVE_VERSION\n"))
"15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
(build-system gnu-build-system)
(supported-systems '("i686-linux" "x86_64-linux"))
- (propagated-inputs
- `(("mescc-tools" ,mescc-tools-0.5.2)
- ("nyacc" ,nyacc-0.86)))
+ (propagated-inputs (list mescc-tools-0.5.2 nyacc-0.86))
(native-inputs
`(("guile" ,guile-2.2)
,@(let ((target-system (or (%current-target-system)
@@ -205,9 +198,7 @@ Guile.")
(base32
"0mnryfkl0dwbr5gxp16j5s95gw7z1vm1fqa1pxabp0aiar1hw53s"))))
(supported-systems '("armhf-linux" "i686-linux" "x86_64-linux"))
- (propagated-inputs
- `(("mescc-tools" ,mescc-tools)
- ("nyacc" ,nyacc-1.00.2)))
+ (propagated-inputs (list mescc-tools nyacc-1.00.2))
(native-search-paths
(list (search-path-specification
(variable "C_INCLUDE_PATH")
@@ -377,7 +368,7 @@ get_machine.")
(base32
"0yyc0fcbbxi9jqa1n76x0rwspdrwmc8g09jlmsw9c35nflrhmz8q"))))
(native-inputs
- `(("mescc-tools" ,mescc-tools)))
+ (list mescc-tools))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))