summaryrefslogtreecommitdiff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-25 22:24:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-26 13:24:28 +0200
commit114a9f1f803b53bd295c44b3719c1ed5dd288e40 (patch)
tree3ad5fc3131b8031265e8678faa46bd0ff55837d2 /gnu/packages/mes.scm
parent0b9da8b5a2dd9bcb2800d60751eb462e3000fa73 (diff)
downloadguix-patches-114a9f1f803b53bd295c44b3719c1ed5dd288e40.tar
guix-patches-114a9f1f803b53bd295c44b3719c1ed5dd288e40.tar.gz
gnu: mescc-tools: Update to 1.2.0.
Fixes <https://issues.guix.gnu.org/49515>. * gnu/packages/mes.scm (mescc-tools-0.5.2): Remove. (mescc-tools): Update to 1.2.0. Use 'git-fetch'. * gnu/packages/make-bootstrap.scm (%mescc-tools-static): Inherit from MESCC-TOOLS rather than MESCC-TOOLS-0.5.2. (%mes-minimal): Inherit from MES rather than MES-0.19. [arguments]: Remove 'delete-file-recursively' for /mes/scaffold.
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm89
1 files changed, 29 insertions, 60 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index ebaf4f547d..71083b5061 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -164,7 +164,7 @@ parsers to allow execution with Guile as extension languages.")))
"15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
(build-system gnu-build-system)
(supported-systems '("i686-linux" "x86_64-linux"))
- (propagated-inputs (list mescc-tools-0.5.2 nyacc-0.86))
+ (propagated-inputs (list mescc-tools nyacc-0.86))
(native-inputs
`(("guile" ,guile-2.2)
,@(let ((target-system (or (%current-target-system)
@@ -295,69 +295,38 @@ Guile.")
(lambda _
(invoke "sh" "install.sh"))))))))
-(define-public mescc-tools-0.5.2
- ;; Mescc-tools used for bootstrap.
- (let ((commit "bb062b0da7bf2724ca40f9002b121579898d4ef7")
- (revision "0")
- (version "0.5.2"))
- (package
- (name "mescc-tools")
- (version (git-version version revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.savannah.nongnu.org/r/mescc-tools.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1nc6rnax66vmhqsjg0kgx23pihdcxmww6v325ywf59vsq1jqjvff"))))
- (build-system gnu-build-system)
- (supported-systems '("i686-linux" "x86_64-linux"))
- (arguments
- `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:test-target "test"
- #:phases (modify-phases %standard-phases
- (delete 'configure))))
- (synopsis "Tools for the full source bootstrapping process")
- (description
- "Mescc-tools is a collection of tools for use in a full source
-bootstrapping process. It consists of the M1 macro assembler, the hex2
-linker, the blood-elf symbol table generator, the kaem shell, exec_enable and
-get_machine.")
- (home-page "https://savannah.nongnu.org/projects/mescc-tools")
- (license gpl3+))))
-
(define-public mescc-tools
(package
- (inherit mescc-tools-0.5.2)
(name "mescc-tools")
- (version "0.7.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://git.savannah.nongnu.org/cgit/mescc-tools.git/snapshot/"
- name "-Release_" version
- ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1p1ijia4rm3002f5sypidl9v5gq0mlch9b0n61rpxkdsaaxjqax3"))))
- (supported-systems '("armhf-linux" "aarch64-linux"
- "i686-linux" "x86_64-linux"))
+ (version "1.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.nongnu.org/r/mescc-tools.git")
+ (commit (string-append "Release_" version))
+ (recursive? #t))) ;for M2libc
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xkn5sspfxldy4wm8fq8gd8kwn46578zhfl12c16pq74x21zb198"))))
+ (build-system gnu-build-system)
+ (supported-systems '("i686-linux" "x86_64-linux"
+ "armhf-linux" "aarch64-linux"
+ "powerpc64le-linux"))
(arguments
- (substitute-keyword-arguments (package-arguments mescc-tools-0.5.2)
- ((#:make-flags _)
- `(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- "CC=gcc"))
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'patch-prefix
- (lambda _
- (substitute* "sha256.sh"
- (("/usr/bin/sha256sum") (which "sha256sum")))
- #t))))))))
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:test-target "test"
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list which))
+ (synopsis "Tools for the full source bootstrapping process")
+ (description
+ "Mescc-tools is a collection of tools for use in a full source
+bootstrapping process. It consists of the M1 macro assembler, the hex2
+linker, the blood-elf symbol table generator, the kaem shell, exec_enable and
+get_machine.")
+ (home-page "https://savannah.nongnu.org/projects/mescc-tools")
+ (license gpl3+)))
(define-public m2-planet
(package