summaryrefslogtreecommitdiff
path: root/gnu/packages/maven.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 14:02:44 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:15:26 +0200
commita18f0a7fd1a073c6a755370c377fe13a24815d51 (patch)
treebe1c30e77301fa0e6d359e707eebbedd16836de6 /gnu/packages/maven.scm
parent6a25a3b1ba837b41e0ba877d1c947c43e91b6ded (diff)
downloadguix-patches-a18f0a7fd1a073c6a755370c377fe13a24815d51.tar
guix-patches-a18f0a7fd1a073c6a755370c377fe13a24815d51.tar.gz
gnu: Add java-sonatype-aether-api.
* gnu/packages/maven.scm (java-sonatype-aether-api): New variable.
Diffstat (limited to 'gnu/packages/maven.scm')
-rw-r--r--gnu/packages/maven.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 00c644c432..757b522d60 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -364,6 +364,40 @@ for repositories using URI-based layouts.")))
(description "This package contains a transport implementation based on
Maven Wagon, for use in Maven.")))
+;; aether is the parent project that was forked into maven-resolver. It used
+;; to be used with older versions of Maven, and is still required for some
+;; plugins and their dependencies. This version is required for the plugins,
+;; even though there are newer versions of this project.
+(define-public java-sonatype-aether-api
+ (package
+ (name "java-sonatype-aether-api")
+ (version "1.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sonatype/sonatype-aether")
+ (commit (string-append "aether-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wn9fv91n40bvlwbzy0dmh0xqibxl2mpzpnbibhqss3c0zlr1ccq"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "aether-api.jar"
+ #:source-dir "aether-api/src/main/java"
+ #:test-dir "aether-api/src/test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'install-parent (install-pom-file "pom.xml"))
+ (replace 'install (install-from-pom "aether-api/pom.xml")))))
+ (propagated-inputs
+ `(("java-sonatype-forge-parent-pom" ,java-sonatype-forge-parent-pom-6)))
+ (native-inputs `(("java-junit" ,java-junit)))
+ (home-page "https://github.com/sonatype/sonatype-aether")
+ (synopsis "Maven repository system API")
+ (description "This package contains the API for the maven repository system.")
+ (license license:asl2.0)))
+
(define-public maven-shared-utils
(package
(name "maven-shared-utils")