summaryrefslogtreecommitdiff
path: root/gnu/packages/maven.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 15:50:08 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:16:21 +0200
commit47b4ed504d945ee87936939cf68e6e5690083e3b (patch)
tree38c5b1838512d829348652a3302a2fef858fead8 /gnu/packages/maven.scm
parent7a85b602ca7102a6141c55c0936fe41757f57a41 (diff)
downloadguix-patches-47b4ed504d945ee87936939cf68e6e5690083e3b.tar
guix-patches-47b4ed504d945ee87936939cf68e6e5690083e3b.tar.gz
gnu: Add java-eclipse-aether-util.
* gnu/packages/maven.scm (java-eclipse-aether-util): New variable.
Diffstat (limited to 'gnu/packages/maven.scm')
-rw-r--r--gnu/packages/maven.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 5e6d7aeaed..82e9db2de6 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -556,6 +556,26 @@ for repository system implementations and repository connectors.")))
(description "This package contains a collection of utility classes to
ease testing of the repository system.")))
+(define-public java-eclipse-aether-util
+ (package
+ (inherit java-eclipse-aether-api)
+ (name "java-eclipse-aether-util")
+ (arguments
+ `(#:jar-name "aether-util.jar"
+ #:source-dir "aether-util/src/main/java"
+ #:test-dir "aether-util/src/test"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install (install-from-pom "aether-util/pom.xml")))))
+ (propagated-inputs
+ `(("java-eclipse-aether-api" ,java-eclipse-aether-api)))
+ (native-inputs
+ `(("java-eclipse-aether-test-util" ,java-eclipse-aether-test-util)
+ ("java-junit" ,java-junit)))
+ (synopsis "Utility classes for the maven repository system")
+ (description "This package contains a collection of utility classes to
+ease usage of the repository system.")))
+
(define-public maven-shared-utils
(package
(name "maven-shared-utils")