summaryrefslogtreecommitdiff
path: root/gnu/packages/maven-parent-pom.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 14:34:24 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:11:29 +0200
commita98ff9b8abcf922e3999905f1513338577e571ab (patch)
tree48b78eb2a547162af542c9b3c57d7ea88b4727c4 /gnu/packages/maven-parent-pom.scm
parent94f2bac18e1436bd7cd0c3572dbf43de019534e1 (diff)
downloadguix-patches-a98ff9b8abcf922e3999905f1513338577e571ab.tar
guix-patches-a98ff9b8abcf922e3999905f1513338577e571ab.tar.gz
gnu: Add java-sonatype-spice-parent-pom-15.
* gnu/packages/maven-parent-pom.scm (java-sonatype-spice-parent-pom-15): New variable.
Diffstat (limited to 'gnu/packages/maven-parent-pom.scm')
-rw-r--r--gnu/packages/maven-parent-pom.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/maven-parent-pom.scm b/gnu/packages/maven-parent-pom.scm
index e64b531cd8..96cf897ebf 100644
--- a/gnu/packages/maven-parent-pom.scm
+++ b/gnu/packages/maven-parent-pom.scm
@@ -201,3 +201,35 @@ other projects as their parent pom.")
(define-public java-sonatype-forge-parent-pom-10
(make-java-sonatype-forge-parent-pom
"10" "1n89wb00q4s9nwpqq6q1h4nzakw1l1rppjygxkl3iid7m5fnj60n"))
+
+(define-public java-sonatype-spice-parent-pom-15
+ (hidden-package
+ (package
+ (name "java-sonatype-spice-parent-pom")
+ (version "15")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sonatype/oss-parents")
+ ;; The only commit where spice-parent is version 15
+ (commit "a4d1169c66fb21b214cb3eff2f056ec3e3695ca7")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h62h6m31srmqnd1bhyspz6hdhkkv48knkj0ximq3pzdixgzyxgy"))))
+ (build-system ant-build-system)
+ (propagated-inputs
+ `(("java-sonatype-forge-parent-pom-5" ,java-sonatype-forge-parent-pom-5)))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build)
+ (delete 'configure)
+ (replace 'install
+ (install-pom-file "pom.xml")))))
+ (home-page "https://github.com/sonatype/oss-parents")
+ (synopsis "Sonatype spice parent pom")
+ (description "This package contains a single pom.xml file that is used by
+other projects as their parent pom.")
+ (license license:asl2.0))))