summaryrefslogtreecommitdiff
path: root/gnu/packages/maven-parent-pom.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 14:30:49 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:11:38 +0200
commit6969a575e4439de46c52ac4c4512804c6e288d69 (patch)
tree62f89a5fedf4de3378443217454d206614e2ac4d /gnu/packages/maven-parent-pom.scm
parent744979f926aac05ab48a3252e9bb362cdf936256 (diff)
downloadguix-patches-6969a575e4439de46c52ac4c4512804c6e288d69.tar
guix-patches-6969a575e4439de46c52ac4c4512804c6e288d69.tar.gz
gnu: Add plexus-parent-pom-3.1.
* gnu/packages/maven-parent-pom.scm (plexus-parent-pom-3.1): New variable.
Diffstat (limited to 'gnu/packages/maven-parent-pom.scm')
-rw-r--r--gnu/packages/maven-parent-pom.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/maven-parent-pom.scm b/gnu/packages/maven-parent-pom.scm
index 6e5a5b03e7..6dbff83b8a 100644
--- a/gnu/packages/maven-parent-pom.scm
+++ b/gnu/packages/maven-parent-pom.scm
@@ -329,3 +329,38 @@ other projects as their parent pom.")
(delete 'build)
(replace 'install
(install-pom-file (assoc-ref %build-inputs "source")))))))))
+
+(define* (make-plexus-parent-pom version hash #:optional parent)
+ (hidden-package
+ (package
+ (name "plexus-parent-pom")
+ (version version)
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/codehaus-plexus/plexus-pom")
+ (commit (string-append "plexus-" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 hash))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (install-pom-file "pom.xml")))))
+ (propagated-inputs
+ (if parent
+ `(("parent" ,parent))
+ '()))
+ (home-page "https://codehaus-plexus.github.io/plexus-pom")
+ (synopsis "Plexus parent pom")
+ (description "This package contains the Plexus parent POM.")
+ (license license:asl2.0))))
+
+(define-public plexus-parent-pom-3.1
+ (make-plexus-parent-pom
+ "3.1" "0r1wa6zrpzynn4028w7880abkk2xk25mipav5f0a4d1abqzy5m53"
+ java-sonatype-spice-parent-pom-17))