summaryrefslogtreecommitdiff
path: root/gnu/packages/maven-parent-pom.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 19:31:32 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:11:57 +0200
commit40b20507d159db3f4b483ac9907cc4f9afbe6ac7 (patch)
treee101d02b701dcb44b4e0d5cf0d8b54983a6e46d7 /gnu/packages/maven-parent-pom.scm
parent7b28106e913f435ef52f57c6b39e5982d8dd478b (diff)
downloadguix-patches-40b20507d159db3f4b483ac9907cc4f9afbe6ac7.tar
guix-patches-40b20507d159db3f4b483ac9907cc4f9afbe6ac7.tar.gz
gnu: Add maven-plugins-pom-23.
* gnu/packages/maven-parent-pom.scm (maven-plugins-pom-23): New variable.
Diffstat (limited to 'gnu/packages/maven-parent-pom.scm')
-rw-r--r--gnu/packages/maven-parent-pom.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/maven-parent-pom.scm b/gnu/packages/maven-parent-pom.scm
index 23b60c7926..6937521252 100644
--- a/gnu/packages/maven-parent-pom.scm
+++ b/gnu/packages/maven-parent-pom.scm
@@ -470,3 +470,33 @@ tool. This package contains the Maven parent POM.")
(("1.5.5")
,(package-version java-plexus-component-annotations)))
#t)))))))))
+
+(define-public maven-plugins-pom-23
+ (hidden-package
+ (package
+ (name "maven-plugins-pom")
+ (version "23")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/apache/maven-plugins")
+ (commit (string-append "maven-plugins-" version))))
+ (file-name (git-file-name "maven-plugins-pom" version))
+ (sha256
+ (base32
+ "1j50il0c9kirr1cvf6vfr86wxp65lwqm9i4bz304ix12vv6ncxjq"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (install-pom-file "pom.xml")))))
+ (propagated-inputs
+ `(("maven-parent-pom" ,maven-parent-pom-22)))
+ (home-page "https://github.com/apache/maven-plugins")
+ (synopsis "Maven parent pom for maven plugins projects")
+ (description "This package contains the parent pom for maven plugins.")
+ (license license:asl2.0))))