summaryrefslogtreecommitdiff
path: root/gnu/packages/maven-parent-pom.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 14:32:34 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:11:14 +0200
commit16466a5d7f13e0824d115388f39f3b9296402ed3 (patch)
tree2f2d631bf0e9f7cbe6f44155df5b823c8a648449 /gnu/packages/maven-parent-pom.scm
parent40448a023600b7b5e876d0a1d2a25878e61de579 (diff)
downloadguix-patches-16466a5d7f13e0824d115388f39f3b9296402ed3.tar
guix-patches-16466a5d7f13e0824d115388f39f3b9296402ed3.tar.gz
gnu: Add java-weld-parent-pom.
* gnu/packages/maven-parent-pom.scm (java-weld-parent-pom): New variable.
Diffstat (limited to 'gnu/packages/maven-parent-pom.scm')
-rw-r--r--gnu/packages/maven-parent-pom.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/maven-parent-pom.scm b/gnu/packages/maven-parent-pom.scm
index e4bfca36fd..f2c2b20be1 100644
--- a/gnu/packages/maven-parent-pom.scm
+++ b/gnu/packages/maven-parent-pom.scm
@@ -131,3 +131,30 @@
(make-apache-commons-parent-pom
"50" "0ki8px35dan51ashblpw6rdl27c2fq62slazhslhq3lr4fwlpvxs"
apache-parent-pom-21))
+
+(define-public java-weld-parent-pom
+ (hidden-package
+ (package
+ (name "java-weld-parent-pom")
+ (version "36")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/weld/parent")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rbvizcsma456mw9fvp4dj9cljh97nswvhi04xhczi38j5bgal0m"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build)
+ (replace 'install
+ (install-pom-file "pom.xml")))))
+ (home-page "https://github.com/weld/parent")
+ (synopsis "Pom parent file for weld projects")
+ (description "This package contains the parent Maven Pom for weld projects.")
+ (license license:asl2.0))))