summaryrefslogtreecommitdiff
path: root/gnu/packages/matrix.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-10 23:26:07 +0100
committerMarius Bakke <marius@gnu.org>2022-01-11 18:36:38 +0100
commit6a86d59e28250771a3a0537108869f8c5bdee0a4 (patch)
treef6a5d1854ad8a15fd82c029e0875f7372c4e8ae9 /gnu/packages/matrix.scm
parente768df37c19efbded660174fb12b3d4dc42c01e0 (diff)
downloadguix-patches-6a86d59e28250771a3a0537108869f8c5bdee0a4.tar
guix-patches-6a86d59e28250771a3a0537108869f8c5bdee0a4.tar.gz
gnu: pantalaimon: Disable sanity check.
* gnu/packages/matrix.scm (pantalaimon)[arguments]: Disable sanity-check phase.
Diffstat (limited to 'gnu/packages/matrix.scm')
-rw-r--r--gnu/packages/matrix.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 8cdfa38b32..1c19eab5c1 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -254,7 +254,10 @@ fledged batteries-included asyncio layer using aiohttp.")
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "tests")))))))
+ (invoke "pytest" "-vv" "tests"))))
+ ;; XXX: The sanity check trips on optional GUI libraries for the
+ ;; panctl command.
+ (delete 'sanity-check))))
(native-inputs
(list python-pytest python-faker python-pytest-aiohttp
python-aioresponses))