summaryrefslogtreecommitdiff
path: root/gnu/packages/matrix.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-10-14 19:05:47 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-15 13:06:11 +0200
commit57f2b19edfb1f4da628876ccd4698199a9a1b724 (patch)
tree1806d5a7bb2765ebf2aba6cc27885922b964f37b /gnu/packages/matrix.scm
parentcecee6ca7656526bc4037acfea193c07a5673c69 (diff)
downloadguix-patches-57f2b19edfb1f4da628876ccd4698199a9a1b724.tar
guix-patches-57f2b19edfb1f4da628876ccd4698199a9a1b724.tar.gz
gnu: synapse: Downgrade to 1.29.0.
As discussed in [1] and [2], python-synapse 1.44.0 does not work with our version of python-cryptography. [1]: https://lists.gnu.org/archive/html/guix-patches/2021-10/msg00732.html [2]: https://issues.guix.gnu.org/issue/48655 This reverts commit a6c30da4dc963e8a6282773fd1c2048d856a6cb4. * gnu/packages/matrix.scm (synapse): Downgrade to 1.29.0. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/matrix.scm')
-rw-r--r--gnu/packages/matrix.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index e6b0b99630..5c2b194d07 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -3,7 +3,6 @@
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
-;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -87,13 +86,13 @@ an LDAP server.")
(define-public synapse
(package
(name "synapse")
- (version "1.44.0")
+ (version "1.29.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "matrix-synapse" version))
(sha256
(base32
- "1lgi1a4ksz4z78yb84bi29x4y080bx1dadib2wznvmwsfif0azx0"))))
+ "0if2yhpz8psg0661401mvxznldbfhk2j9rhbs25jdaqm9jsv6907"))))
(build-system python-build-system)
;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
(propagated-inputs