summaryrefslogtreecommitdiff
path: root/gnu/packages/matrix.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-03 21:43:49 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-05 19:33:09 +0200
commit2d84d653164ea932540bd27e518a2ed6f8658f96 (patch)
treeed77e8c721d00477f73e07df821cf1def52fb93d /gnu/packages/matrix.scm
parent6f07472ab2ded3effd98565330b1f8b21d721961 (diff)
downloadguix-patches-2d84d653164ea932540bd27e518a2ed6f8658f96.tar
guix-patches-2d84d653164ea932540bd27e518a2ed6f8658f96.tar.gz
gnu: synapse: Update to 1.14.0.
* gnu/packages/matrix.scm (synapse): Update to 1.14.0.
Diffstat (limited to 'gnu/packages/matrix.scm')
-rw-r--r--gnu/packages/matrix.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 7bbdc09688..002c1b530d 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -59,15 +60,15 @@ an LDAP server.")
(define-public synapse
(package
(name "synapse")
- (version "1.11.0")
+ (version "1.14.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "matrix-synapse" version))
(sha256
(base32
- "0cqbwcz0fi4w413s1kcxvf696qi4n46n1k4ggnygqri5yq26qlfy"))))
+ "09drdqcjvpk9s3hq5rx9yxsxq0wak5fg5gfaiqfnbnxav2c2v7kq"))))
(build-system python-build-system)
- ;; TODO I think there are custom tests
+ ;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
(propagated-inputs
`(("python-simplejson" ,python-simplejson) ; not attested but required
;; requirements (synapse/python_dependencies.py)
@@ -100,6 +101,7 @@ an LDAP server.")
("python-bleach" ,python-bleach)
("python-typing-extensions" ,python-typing-extensions)
;; conditional requirements (synapse/python_dependencies.py)
+ ;;("python-hiredis" ,python-hiredis)
("python-matrix-synapse-ldap3" ,python-matrix-synapse-ldap3)
("python-psycopg2" ,python-psycopg2)
("python-jinja2" ,python-jinja2)