summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-07-30 23:20:38 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-08-16 17:30:55 -0400
commite79fe4f675dc7e56e3d5058cca5aef9fb2efe785 (patch)
treef71cead64d29918ec1b9d3153692b9534166b2b0 /gnu/packages/maths.scm
parentbc549a276cd9c10202427d220d87f50eb3784d42 (diff)
downloadguix-patches-e79fe4f675dc7e56e3d5058cca5aef9fb2efe785.tar
guix-patches-e79fe4f675dc7e56e3d5058cca5aef9fb2efe785.tar.gz
gnu: wxmaxima: Update to 20.06.6.
* gnu/packages/maths.scm (wxmaxima): Update to 20.06.6. [arguments]: Add 'patch-doc-path phase.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 461c286044..e3209c1e50 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3383,7 +3383,7 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- (version "20.04.0")
+ (version "20.06.6")
(source
(origin
(method git-fetch)
@@ -3392,7 +3392,7 @@ point numbers.")
(commit (string-append "Version-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0vrjxzfgmjdzm1rgl0crz4b4badl14jwh032y3xkcdvjl5j67lp3"))))
+ (base32 "054f7n5kx75ng5j20rd5q27n9xxk03mrd7sbxyym1lsswzimqh4w"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -3410,6 +3410,14 @@ point numbers.")
`(#:test-target "test"
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-doc-path
+ (lambda _
+ ;; Don't look in share/doc/wxmaxima-xx.xx.x for the
+ ;; documentation. Only licensing information is placed there by
+ ;; Guix.
+ (substitute* "src/Dirstructure.cpp"
+ (("/doc/wxmaxima-\\%s") "/doc/wxmaxima"))
+ #t))
(add-before 'check 'pre-check
(lambda _
;; Tests require a running X server.