summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2019-11-28 22:11:55 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-07 12:25:09 +0100
commite6de152dc17df5fb15a618214efe375582919442 (patch)
treea47d6a99a49aa8671206dea815f05703913ed920 /gnu/packages/maths.scm
parentcd5406effa34fa5cfda7eb7bbd2ccaf5201cf523 (diff)
downloadguix-patches-e6de152dc17df5fb15a618214efe375582919442.tar
guix-patches-e6de152dc17df5fb15a618214efe375582919442.tar.gz
gnu: lapack: Update to 3.9.0.
* gnu/packages/maths.scm (lapack): Update to 3.9.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm18
1 files changed, 5 insertions, 13 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0ed61ad4a1..be6e5b21e4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -583,7 +583,7 @@ large scale eigenvalue problems.")
(define-public lapack
(package
(name "lapack")
- (version "3.7.1")
+ (version "3.9.0")
(source
(origin
(method url-fetch)
@@ -591,26 +591,18 @@ large scale eigenvalue problems.")
version ".tgz"))
(sha256
(base32
- "1j51r7n5w4k7r3lrvy7710xrpkg40wf4rqnmngfz6ck9ypckzign"))))
+ "1155qixp26c12yrxc76z9mlfw2h3xxymxxv5znpgzh5gaykpndgj"))))
(build-system cmake-build-system)
(home-page "http://www.netlib.org/lapack/")
(inputs `(("fortran" ,gfortran)
- ("python" ,python-2)))
+ ("python" ,python-wrapper)))
(arguments
`(#:configure-flags (list
"-DBUILD_SHARED_LIBS:BOOL=YES"
"-DLAPACKE=ON"
-
;; Build the 'LAPACKE_clatms' functions.
- "-DLAPACKE_WITH_TMG=ON")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'patch-python
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((python (assoc-ref inputs "python")))
- (substitute* "lapack_testing.py"
- (("/usr/bin/env python") python)))
- #t)))))
+ "-DLAPACKE_WITH_TMG=ON"
+ "-DBUILD_TESTING=ON")))
(synopsis "Library for numerical linear algebra")
(description
"LAPACK is a Fortran 90 library for solving the most commonly occurring