summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-09 11:27:52 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-10 23:39:12 +0100
commite62be58fc35dac1980f59331545d36e7865efc77 (patch)
treeb3aa4a47784448e1e6d9f657e2c413ee663df6eb /gnu/packages/maths.scm
parente1605e36a804d5d67fd926ea529d9bab38bc87b7 (diff)
downloadguix-patches-e62be58fc35dac1980f59331545d36e7865efc77.tar
guix-patches-e62be58fc35dac1980f59331545d36e7865efc77.tar.gz
gnu: Add openspecfun.
* gnu/packages/maths.scm (openspecfun): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 24c4149587..c1f270a721 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1028,6 +1028,43 @@ environments.")
license:public-domain
license:lgpl2.1+))))
+(define-public openspecfun
+ (package
+ (name "openspecfun")
+ (version "0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/JuliaLang/openspecfun/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0nsa3jjmlhcqkw5ba5ypbn3n0c8b6lc22zzlxnmxkxi9shhdx65z"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;no "check" target
+ #:make-flags
+ (list (string-append "prefix=" (assoc-ref %outputs "out")))
+ ;; no configure script
+ #:phases (alist-delete 'configure %standard-phases)))
+ (inputs
+ `(("fortran" ,gfortran-4.8)))
+ (home-page "https://github.com/JuliaLang/openspecfun")
+ (synopsis "Collection of special mathematical functions")
+ (description
+ "Openspecfun provides AMOS and Faddeeva. AMOS (from Netlib) is a
+portable package for Bessel Functions of a Complex Argument and Nonnegative
+Order; it contains subroutines for computing Bessel functions and Airy
+functions. Faddeeva allows computing the various error functions of arbitrary
+complex arguments (Faddeeva function, error function, complementary error
+function, scaled complementary error function, imaginary error function, and
+Dawson function); given these, one can also easily compute Voigt functions,
+Fresnel integrals, and similar related functions as well.")
+ ;; Faddeeva is released under the Expat license; AMOS is included as
+ ;; public domain software.
+ (license (list license:expat license:public-domain))))
+
(define-public atlas
(package
(name "atlas")