summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-12 04:10:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-12 04:10:59 +0200
commitc9e676d0b141f510c19e26edb1e6fad079b9b502 (patch)
tree79abb4a4b92ecf4504a46e55ffa7971a06c8a5df /gnu/packages/maths.scm
parentd45720d8b456e82380601d77e25bd05c6e0dc36a (diff)
parentdcb7ce500bd025455982d74c3384c707f35bbb46 (diff)
downloadguix-patches-c9e676d0b141f510c19e26edb1e6fad079b9b502.tar
guix-patches-c9e676d0b141f510c19e26edb1e6fad079b9b502.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f350726e41..8e2149d7d5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -482,6 +482,45 @@ in arbitrary dimension. It can also be used for the converse operation of
computing convex hulls.")
(license license:gpl2+)))
+(define-public lrslib
+ (package
+ (name "lrslib")
+ (version "7.0a")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://cgm.cs.mcgill.ca/~avis/C/lrslib/archive/"
+ "lrslib-0"
+ (string-delete #\. version) ".tar.gz"))
+ (sha256
+ (base32
+ "034fa45r9hwx6ljmgpxk2872q34nklkalpdkc6s9hqw57rivi36k"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gmp" ,gmp)))
+ (arguments
+ `(#:tests? #f ; no check phase
+ #:make-flags `("CC=gcc"
+ ,(string-append "prefix=" (assoc-ref %outputs "out"))
+ "all-shared")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* "makefile"
+ (("-L \\.") "-L . -Wl,-rpath='$$ORIGIN/../lib'"))
+ #t)))))
+ (home-page "http://cgm.cs.mcgill.ca/~avis/C/lrs.html")
+ (synopsis "Convex hulls of polyhedra with exact arithmetic")
+ (description
+ "The C code of lrslib implements the reverse search algorithm for
+vertex enumeration and convex hull problems. Its input file format is
+compatible with cddlib. All computations are done exactly in either
+multiple precision or fixed integer arithmetic. Output is not stored
+in memory, so even problems with very large output sizes can sometimes
+be solved.")
+ (license license:gpl2+)))
+
(define-public arpack-ng
(package
(name "arpack-ng")