summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-09-18 14:05:51 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-09-18 14:05:51 +0200
commitade7638d84779b58d5a4c961666bcb35ebf43394 (patch)
tree09c069a51d25c16d482bf0453c8e19cbaed6c3a9 /gnu/packages/maths.scm
parentcd6ec6706c4da76866b83d830ed686b9d036641c (diff)
downloadguix-patches-ade7638d84779b58d5a4c961666bcb35ebf43394.tar
guix-patches-ade7638d84779b58d5a4c961666bcb35ebf43394.tar.gz
Revert "gnu: openblas: Update to 0.3.10."
This reverts commit c59e9f0a03241ef3c7b8042054fd54e327f7539a because it triggers too many rebuilds.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index dd4d34615b..ce393cba80 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -40,7 +40,6 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
-;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3610,17 +3609,16 @@ parts of it.")
(define-public openblas
(package
(name "openblas")
- (version "0.3.10")
+ (version "0.3.9")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/xianyi/OpenBLAS")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/openblas/v" version "/OpenBLAS%20"
+ version "%20version.tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "174id98ga82bhz2v7sy9yj6pqy0h0088p3mkdikip69p9rh3d17b"))))
+ "14iz9xnrb9xiwgj84j94mc74gg0zn2vsy9fmsijxxma1n7dck4w3"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"