summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-29 16:15:52 +0000
committerLudovic Courtès <ludo@gnu.org>2021-05-05 16:56:44 +0200
commitadc96e1db3ba97882a35240ffbaf74c9c4eec0c1 (patch)
tree960350fda1c7ff745283f1486715164b122dc013 /gnu/packages/maths.scm
parent9661eb86e048d76fd6d64587b28560a6c98f62b8 (diff)
downloadguix-patches-adc96e1db3ba97882a35240ffbaf74c9c4eec0c1.tar
guix-patches-adc96e1db3ba97882a35240ffbaf74c9c4eec0c1.tar.gz
gnu: Add libcerf.
* gnu/packages/maths.scm (libcerf): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d3656f0405..d5a94e92ab 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
@@ -698,6 +698,30 @@ in memory, so even problems with very large output sizes can sometimes
be solved.")
(license license:gpl2+)))
+(define-public libcerf
+ (package
+ (name "libcerf")
+ (version "1.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://jugit.fz-juelich.de/mlz/libcerf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ic2q7kvxpqmgxlishygvx8d00i4wn51vkq4fyac44ahhf6c3kwd"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("perl" ,perl)))
+ (home-page "https://jugit.fz-juelich.de/mlz/libcerf")
+ (synopsis "Library for complex error functions")
+ (description
+ "@code{libcerf} is a self-contained numeric library that provides an
+efficient and accurate implementation of complex error functions, along with
+Dawson, Faddeeva, and Voigt functions.")
+ (license license:expat)))
+
(define-public vinci
(package
(name "vinci")