summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-12-18 13:36:59 +0000
committerLudovic Courtès <ludo@gnu.org>2022-01-20 15:28:15 +0100
commitad0a7a16d91911fcee46dfe62d8206a7721f024b (patch)
tree48906ec5e25ea984c8c63628ed56cd3b04283b67 /gnu/packages/maths.scm
parentadc65e96916ebcd70d5b2b3899e7fee9d9c887c2 (diff)
downloadguix-patches-ad0a7a16d91911fcee46dfe62d8206a7721f024b.tar
guix-patches-ad0a7a16d91911fcee46dfe62d8206a7721f024b.tar.gz
gnu: dune-functions: Update to 2.7.1.
* gnu/packages/maths.scm (dune-functions): Update to 2.7.1. [arguments]: Parallelize build-tests phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7db9bc8f01..9248f7fadf 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6789,7 +6789,7 @@ operating on statically typed trees of objects.")
(define-public dune-functions
(package
(name "dune-functions")
- (version "2.7.0")
+ (version "2.7.1")
(source
(origin
(method git-fetch)
@@ -6799,7 +6799,7 @@ operating on statically typed trees of objects.")
(file-name (git-file-name name version))
(sha256
(base32
- "1na4gcih0kin37ksj2xj07ds04v7zx53pjdhm1hzy55jjfqdjk8h"))))
+ "04dhr4asnl38bf1gp8hrk31maav33m7q71lhl2n5yk1q1x6i77nw"))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -6811,8 +6811,12 @@ operating on statically typed trees of objects.")
"--exclude-regex gridviewfunctionspacebasistest")
#t))
(add-after 'build 'build-tests
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "build_tests" make-flags))))))
+ (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+ (apply invoke "make" "build_tests"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))))
(inputs
(list dune-common
dune-istl