summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-05-02 13:28:28 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-03 18:02:27 +0200
commita3b6a4df6c51cfc49f6ae71254a1d4bfb6b8b5d0 (patch)
treee2812fa892fe754cf935c278a302f55bb4a819dc /gnu/packages/maths.scm
parent7855a9366b2f5248d8fffab93c108abef8146f40 (diff)
downloadguix-patches-a3b6a4df6c51cfc49f6ae71254a1d4bfb6b8b5d0.tar
guix-patches-a3b6a4df6c51cfc49f6ae71254a1d4bfb6b8b5d0.tar.gz
gnu: petsc-openmpi: Fix header inclusions.
* gnu/packages/maths.scm (petsc-openmpi)[arguments]: Add 'patch-header-inclusions' phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index fcd9c5482f..2922d95a70 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3174,7 +3174,16 @@ scientific applications modeled by partial differential equations.")
(("libptesmumps") "libesmumps")
(("libptscotchparmetis") "libptscotchparmetisv3"))))
(add-before 'configure 'mpi-setup
- #$%openmpi-setup)))))
+ #$%openmpi-setup)
+ (add-after 'install 'patch-header-inclusions
+ ;; TODO: Replace with ‘patch-header-inclusions’ when (some form
+ ;; of) https://issues.guix.gnu.org/54780#19 is merged.
+ (lambda _
+ (substitute* (string-append #$output "/include/petsclayouthdf5.h")
+ (("<(H5Ipublic.h)>" _ header)
+ (format #f "<~a/include/~a>"
+ #$(this-package-input "hdf5-parallel-openmpi")
+ header)))))))))
(synopsis "Library to solve PDEs (with MUMPS and MPI support)")))
(define-public petsc-complex-openmpi