summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-04 16:11:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-04 16:15:15 +0200
commita2da6074d041afc22eb9258394c31681711fb16c (patch)
tree06cb5b27e3a3e9d7c2d6524e9aa29202a86d4d52 /gnu/packages/maths.scm
parent08f35b9b6ca635f439bc2b01965aeb73e7ec282d (diff)
downloadguix-patches-a2da6074d041afc22eb9258394c31681711fb16c.tar
guix-patches-a2da6074d041afc22eb9258394c31681711fb16c.tar.gz
gnu: suitesparse: Install libraries into /lib.
* gnu/packages/maths.scm (suitesparse)[arguments]: Add to configure-flags to install programs built with cmake to use 'lib', not 'lib64.'
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0ba6b3444e..7866bcc6eb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2018, 2020 Kei Kebreau <kkebreau@posteo.net>
@@ -3928,7 +3928,8 @@ Fresnel integrals, and similar related functions as well.")
" -DCMAKE_C_FLAGS_RELEASE=\"$(CFLAGS) $(CPPFLAGS)\""
" -DCMAKE_CXX_FLAGS_RELEASE=\"$(CXXFLAGS) $(CPPFLAGS)\""
" -DCMAKE_SKIP_RPATH=TRUE"
- " -DCMAKE_BUILD_TYPE=Release")
+ " -DCMAKE_BUILD_TYPE=Release"
+ " -DCMAKE_INSTALL_LIBDIR=lib")
(string-append "INSTALL_LIB="
(assoc-ref %outputs "out") "/lib")
(string-append "INSTALL_INCLUDE="