summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-05 17:57:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:57:35 +0100
commit9d5aa009062a49bd035ae33e37f6562526e7d38c (patch)
tree4ff2302863a5cf9f3cf604240ea793152156f532 /gnu/packages/maths.scm
parent60bd56c6d8368c23dcd97b26501771c82316fc8c (diff)
parent2c2fc24b899d3286774f60405888718d98211213 (diff)
downloadguix-patches-9d5aa009062a49bd035ae33e37f6562526e7d38c.tar
guix-patches-9d5aa009062a49bd035ae33e37f6562526e7d38c.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm176
1 files changed, 55 insertions, 121 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index fd7159a411..f350726e41 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2018 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
+;;; Copyright © 2019 Robert Smith <robertsmith@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,7 +62,6 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
- #:use-module (guix build-system r)
#:use-module (guix build-system ruby)
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
@@ -2340,45 +2340,6 @@ sparse system of linear equations A x = b using Gaussian elimination.")
(inputs
(alist-delete "pt-scotch" (package-inputs mumps-openmpi)))))
-(define-public r-quadprog
- (package
- (name "r-quadprog")
- (version "1.5-7")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "quadprog" version))
- (sha256
- (base32
- "0vg7i9p241bwvfdspjbydjrsvgipl6nsb8bjigp0hbbgvxbixx0s"))))
- (build-system r-build-system)
- (native-inputs
- `(("gfortran" ,gfortran)))
- (home-page "https://cran.r-project.org/web/packages/quadprog")
- (synopsis "Functions to solve quadratic programming problems")
- (description
- "This package contains routines and documentation for solving quadratic
-programming problems.")
- (license license:gpl3+)))
-
-(define-public r-pracma
- (package
- (name "r-pracma")
- (version "2.2.5")
- (source (origin
- (method url-fetch)
- (uri (cran-uri "pracma" version))
- (sha256
- (base32 "0isd3s0i4mzmva8lkh0j76hwjy1w50q7d1n9lhxsnnkgalx3xs1g"))))
- (build-system r-build-system)
- (home-page "https://cran.r-project.org/web/packages/pracma/")
- (synopsis "Practical numerical math functions")
- (description "This package provides functions for numerical analysis and
-linear algebra, numerical optimization, differential equations, plus some
-special functions. It uses Matlab function names where appropriate to simplify
-porting.")
- (license license:gpl3+)))
-
(define-public ruby-asciimath
(package
(name "ruby-asciimath")
@@ -2990,7 +2951,7 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- (version "19.09.0")
+ (version "19.11.1")
(source
(origin
(method git-fetch)
@@ -2999,7 +2960,7 @@ point numbers.")
(commit (string-append "Version-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "195j6j8z0jd6xg3a63ywbrbsc6dany795m3fb95nbx1vq0bqqvvn"))))
+ (base32 "16xizaddb27432n1083y89ir5zdqvllsgbwrzzk4jc2rw1ldxfsv"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)))
@@ -3112,12 +3073,8 @@ parts of it.")
(define-public openblas
(package
- ;; TODO: Incorporate 'openblas/fixed-num-threads' changes on the next
- ;; rebuild cycle.
- (replacement openblas/fixed-num-threads)
-
(name "openblas")
- (version "0.3.6")
+ (version "0.3.7")
(source
(origin
(method url-fetch)
@@ -3126,7 +3083,7 @@ parts of it.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1r2g9zzwq5dm8vjd19pxwggfvfzy56cvkmpmp5d014qr3svgmsap"))))
+ "0jbdjsi0qsxahdcm42agnn1y7xpmg0hrhwjsxg0zbhs9wwy3p568"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -3143,6 +3100,13 @@ parts of it.")
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"SHELL=bash"
"MAKE_NB_JOBS=0" ;use jobserver for submakes
+
+ ;; This is the maximum number of threads OpenBLAS will ever use (that
+ ;; is, if $OPENBLAS_NUM_THREADS is greater than that, then NUM_THREADS
+ ;; is used.) If we don't set it, the makefile sets it to the number
+ ;; of cores of the build machine, which is obviously wrong.
+ "NUM_THREADS=128"
+
;; Build the library for all supported CPUs. This allows
;; switching CPU targets at runtime with the environment variable
;; OPENBLAS_CORETYPE=<type>, where "type" is a supported CPU type.
@@ -3197,24 +3161,6 @@ parts of it.")
(synopsis "Optimized BLAS library based on GotoBLAS (ILP64 version)")
(license license:bsd-3)))
-(define openblas/fixed-num-threads
- ;; TODO: Move that to 'openblas' proper on the next rebuild cycle.
- (package
- (inherit openblas)
- (version (match (string-split (package-version openblas) #\.)
- ((numbers ... (= string-length len))
- (string-join (append numbers
- (list (make-string len #\a)))
- "."))))
- (arguments
- (substitute-keyword-arguments (package-arguments openblas)
- ((#:make-flags flags ''())
- ;; This is the maximum number of threads OpenBLAS will ever use (that
- ;; is, if $OPENBLAS_NUM_THREADS is greater than that, then NUM_THREADS
- ;; is used.) If we don't set it, the makefile sets it to the number
- ;; of cores of the build machine, which is obviously wrong.
- `(cons "NUM_THREADS=128" ,flags))))))
-
(define* (make-blis implementation #:optional substitutable?)
"Return a BLIS package with the given IMPLEMENTATION (see config/ in the
source tree for a list of implementations.)
@@ -4146,7 +4092,7 @@ as equations, scalars, vectors, and matrices.")
(define-public z3
(package
(name "z3")
- (version "4.8.6")
+ (version "4.8.7")
(home-page "https://github.com/Z3Prover/z3")
(source (origin
(method git-fetch)
@@ -4155,7 +4101,7 @@ as equations, scalars, vectors, and matrices.")
(file-name (git-file-name name version))
(sha256
(base32
- "1sywcqj5y8yp28m4cdvzsgw74kd6zr1s3y1x17ky8pr9prvpvl6x"))))
+ "0hprcdwhhyjigmhhk6514m71bnmvqci9r8gglrqilgx424r6ff7q"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -4381,57 +4327,6 @@ analysed.")
(arguments
'(#:configure-flags '("-DMCRL2_ENABLE_GUI_TOOLS=OFF")))))
-(define-public r-subplex
- (package
- (name "r-subplex")
- (version "1.5-4")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "subplex" version))
- (sha256
- (base32
- "10cbgbx1bgsax5z7gz6716g360xpq4mvq19cf4qqrxv02mmwz57z"))))
- (build-system r-build-system)
- (native-inputs
- `(("gfortran" ,gfortran)))
- (home-page "https://cran.r-project.org/web/packages/subplex")
- (synopsis "Unconstrained optimization using the subplex algorithm")
- (description "This package implements the Subplex optimization algorithm.
-It solves unconstrained optimization problems using a simplex method on
-subspaces. The method is well suited for optimizing objective functions that
-are noisy or are discontinuous at the solution.")
- (license license:gpl3+)))
-
-(define-public r-desolve
- (package
- (name "r-desolve")
- (version "1.24")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "deSolve" version))
- (sha256
- (base32
- "0hkvspq0fp8j64l9zayab2l2nazazhwfgfym0jllh0xv5a12r99s"))))
- (properties `((upstream-name . "deSolve")))
- (build-system r-build-system)
- (native-inputs
- `(("gfortran" ,gfortran)))
- (home-page "https://desolve.r-forge.r-project.org/")
- (synopsis "Solvers for initial value problems of differential equations")
- (description "This package provides functions that solve initial
-value problems of a system of first-order ordinary differential equations (ODE),
-of partial differential equations (PDE), of differential algebraic equations
-(DAE), and of delay differential equations. The functions provide an interface
-to the FORTRAN functions lsoda, lsodar, lsode, lsodes of the ODEPACK collection,
-to the FORTRAN functions dvode and daspk and a C-implementation of solvers of
-the Runge-Kutta family with fixed or variable time steps. The package contains
-routines designed for solving ODEs resulting from 1-D, 2-D and 3-D partial
-differential equations (PDE) that have been converted to ODEs by numerical
-differencing.")
- (license license:gpl2+)))
-
(define-public tcalc
(package
(name "tcalc")
@@ -5104,7 +4999,7 @@ management via the GIMPS project's Primenet server.")
(define-public nauty
(package
(name "nauty")
- (version "2.6r11")
+ (version "2.6r12")
(source (origin
(method url-fetch)
(uri (string-append
@@ -5113,7 +5008,7 @@ management via the GIMPS project's Primenet server.")
".tar.gz"))
(sha256
(base32
- "05z6mk7c31j70md83396cdjmvzzip1hqb88pfszzc6k4gy8h3m2y"))))
+ "1p4mxf8q5wm47nxyskxbqwa5p1vvkycv1zgswvnk9nsn6vff0al6"))))
(build-system gnu-build-system)
(outputs '("out" "lib"))
(arguments
@@ -5241,3 +5136,42 @@ fields of knowledge.")
(home-page "http://speedcrunch.org/")
(license license:gpl2+)))
+(define-public minisat
+ ;; This is the last commit which is available upstream, no
+ ;; release happened since 2010.
+ (let ((commit "37dc6c67e2af26379d88ce349eb9c4c6160e8543")
+ (revision "1"))
+ (package
+ (name "minisat")
+ (version (string-append "2.2.0-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/niklasso/minisat.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "091hf3qkm197s5r7xcr3m07xsdwyz2rqk1hc9kj0hn13imz09irq"))
+ (patches
+ (search-patches "minisat-friend-declaration.patch"
+ "minisat-install.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list (string-append "prefix=" %output))
+ #:tests? #f ;no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("zlib:static" ,zlib "static")
+ ("zlib" ,zlib)))
+ (synopsis
+ "Small, yet efficient, SAT solver")
+ (description
+ "MiniSat is a minimalistic, open-source SAT solver, developed to help
+researchers and developers alike to get started on SAT.")
+ (home-page
+ "http://minisat.se/MiniSat.html")
+ (license license:expat))))