summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2021-02-08 13:16:17 -0600
committerEric Bavier <bavier@member.fsf.org>2021-02-08 13:25:34 -0600
commit8effdd19691576a79aa4a1e26263b251376e25e5 (patch)
treea2573f998f8a9ed90c9c10c6bcf45442bd3c2f7e /gnu/packages/maths.scm
parenta613abeb43b1c81d2d0e647dc2b3c7f8cc98b8cb (diff)
downloadguix-patches-8effdd19691576a79aa4a1e26263b251376e25e5.tar
guix-patches-8effdd19691576a79aa4a1e26263b251376e25e5.tar.gz
gnu: hdf5: Update to 1.8.22.
Fixes CVE-2018-14033, CVE-2018-11206, CVE-2018-13870, CVE-2018-13869, and CVE-2018-17435 * gnu/packages/maths.scm (hdf5-1.8): Update to 1.8.22. * gnu/packages/patches/hdf5-1.8-mpi-deprecations.patch: Delete upstreamed patch. * gnu/local/mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index eff1480e62..b572f8dee4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015, 2016, 2019, 2020 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2016, 2017 John Darrington <jmd@gnu.org>
-;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
@@ -1077,7 +1077,7 @@ incompatible with HDF5.")
(define-public hdf5-1.8
(package
(name "hdf5")
- (version "1.8.21")
+ (version "1.8.22")
(source
(origin
(method url-fetch)
@@ -1092,9 +1092,8 @@ incompatible with HDF5.")
(string-append major minor)))
"/src/hdf5-" version ".tar.bz2")))
(sha256
- (base32 "03glk4w4wyb1jyb443g53y3y1ncnf6mj2cqwm6avfr2awkgb3cg5"))
- (patches (search-patches "hdf5-config-date.patch"
- "hdf5-1.8-mpi-deprecations.patch"))))
+ (base32 "194ki2s5jrgl4czkvy5nc9nwjyapah0fj72l0gb0aysplp38i6v8"))
+ (patches (search-patches "hdf5-config-date.patch"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)))