summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-09-29 08:01:05 -0400
committerLudovic Courtès <ludo@gnu.org>2020-10-01 12:45:38 +0200
commit786a04c9ae3d69d1fe32999cd94b81efeb72c9fe (patch)
tree8ebbb7e827f2e1a88551839ec424aea9c738041e /gnu/packages/maths.scm
parente9cbf43ae07f1b4c4c047e072c9aa021b64eace8 (diff)
downloadguix-patches-786a04c9ae3d69d1fe32999cd94b81efeb72c9fe.tar
guix-patches-786a04c9ae3d69d1fe32999cd94b81efeb72c9fe.tar.gz
gnu: SuiteSparse: Update to 5.8.1.
From 0d8692dfebc6ac4b515c06612ab8da4c898719eb Mon Sep 17 00:00:00 2001 From: Greg Hogan <code@greghogan.com> Date: Tue, 29 Sep 2020 11:54:38 +0000 Subject: [PATCH] gnu: SuiteSparse: Update to 5.8.1. * gnu/packages/maths.scm (suitesparse): Update to 5.8.1. [arguments]: Remove unnecessary flag and use default blas and lapack. [inputs]: Add new dependencies for SLIP_LU component. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 93ee2db60a..232ef40b9c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3862,7 +3862,7 @@ Fresnel integrals, and similar related functions as well.")
(define-public suitesparse
(package
(name "suitesparse")
- (version "5.7.1")
+ (version "5.8.1")
(source
(origin
(method git-fetch)
@@ -3872,7 +3872,7 @@ Fresnel integrals, and similar related functions as well.")
(file-name (git-file-name name version))
(sha256
(base32
- "174p3l78kv9gaa0i5hflyai2ydwnjzh34k9938sl4aa3li0543s8"))
+ "0qjlyfxs8s48rs63c2fzspisgq1kk4bwkgnhmh125hgkdhrq2w1c"))
(patches (search-patches "suitesparse-mongoose-cmake.patch"))
(modules '((guix build utils)))
(snippet
@@ -3885,7 +3885,6 @@ Fresnel integrals, and similar related functions as well.")
'(#:tests? #f ;no "check" target
#:make-flags
(list "CC=gcc"
- "BLAS=-lblas"
"TBB=-ltbb"
"MY_METIS_LIB=-lmetis"
;; Flags for cmake (required to build GraphBLAS and Mongoose)
@@ -3907,6 +3906,8 @@ Fresnel integrals, and similar related functions as well.")
(inputs
`(("tbb" ,tbb)
("lapack" ,lapack)
+ ("gmp" ,gmp)
+ ("mpfr" ,mpfr)
("metis" ,metis)))
(native-inputs
`(("cmake" ,cmake-minimal)