summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-04-27 13:29:21 -0400
committerKei Kebreau <kkebreau@posteo.net>2021-04-29 00:44:03 -0400
commit685e4733ad2ec8ad3e6f575bf561f14b988bef55 (patch)
tree5432f8bf4755422818897a494496b3a6d36f1119 /gnu/packages/maths.scm
parentd018a11ee065e0f6bafb33fcc1a130aa7900b5a3 (diff)
downloadguix-patches-685e4733ad2ec8ad3e6f575bf561f14b988bef55.tar
guix-patches-685e4733ad2ec8ad3e6f575bf561f14b988bef55.tar.gz
gnu: xaos: Update to 4.2.1.
* gnu/packages/maths.scm (xaos): Update to 4.2.1. [arguments]: Patch call to "lrelease" in XaoS.pro.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1f4e2c2e6f..4f5e0e5cf7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4480,7 +4480,7 @@ evaluates expressions using the standard order of operations.")
(define-public xaos
(package
(name "xaos")
- (version "4.0")
+ (version "4.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4489,7 +4489,7 @@ evaluates expressions using the standard order of operations.")
(file-name (git-file-name name version))
(sha256
(base32
- "00110p5xscjsmn7avfqgydn656zbmdj3l3y2fpv9b4ihzpid8n7a"))))
+ "0maw5am6rrkyjrprfg113zjq37mqj0iaznkg4h2927ff7wrprc94"))))
(build-system gnu-build-system)
(native-inputs `(("gettext" ,gettext-minimal)
("qtbase" ,qtbase)
@@ -4512,12 +4512,14 @@ evaluates expressions using the standard order of operations.")
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- ;; The DESTDIR is originally set to install the xaos binary to
- ;; the "bin" folder inside the build directory. Setting make
- ;; flags doesn't seem to change this.
(substitute* "XaoS.pro"
+ ;; The DESTDIR is originally set to install the xaos binary to
+ ;; the "bin" folder inside the build directory. Setting make
+ ;; flags doesn't seem to change this.
(("DESTDIR.*$")
- (string-append "DESTDIR=" out "/bin")))
+ (string-append "DESTDIR=" out "/bin"))
+ ;; Set the correct path to the lrelease binary.
+ (("lrelease-qt5") "lrelease"))
(substitute* "src/include/config.h"
(("/usr/share/XaoS")
(string-append out "/share/XaoS")))