summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-20 12:11:35 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-23 10:38:06 +0100
commit61a529b421471213739700da179cc3adc82585e9 (patch)
tree97472d43577e63578cd7f4d7d44058904d43ff00 /gnu/packages/maths.scm
parent2742f87e17eb81088e041b363bb2f854b22a27bc (diff)
downloadguix-patches-61a529b421471213739700da179cc3adc82585e9.tar
guix-patches-61a529b421471213739700da179cc3adc82585e9.tar.gz
gnu: Add double-conversion.
* gnu/packages/maths.scm (double-conversion): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0d2efdde26..cb6fa66201 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -92,6 +92,32 @@ effectively as a scientific calculator.")
(license license:gpl3+)
(home-page "http://www.gnu.org/software/units/")))
+(define-public double-conversion
+ (package
+ (name "double-conversion")
+ (version "1.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/floitsch/double-conversion/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cnr8xhyjfxijay8ymkqcph3672wp2lj23qhdmr3m4kia5kpdf83"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:test-target "test"
+ #:configure-flags '("-DBUILD_SHARED_LIBS=ON"
+ "-DBUILD_TESTING=ON")))
+ (home-page "https://github.com/floitsch/double-conversion")
+ (synopsis "Conversion routines for IEEE doubles")
+ (description
+ "The double-conversion library provides binary-decimal and decimal-binary
+routines for IEEE doubles. The library consists of efficient conversion
+routines that have been extracted from the V8 JavaScript engine.")
+ (license license:bsd-3)))
+
(define-public dionysus
(package
(name "dionysus")