summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-08-26 00:46:42 +0200
committerLudovic Courtès <ludo@gnu.org>2020-08-26 00:51:57 +0200
commit51c55cedda6c69ba68da6be88176b847effa6479 (patch)
tree741d4e9349f84fdef92213f24d853c7208029813 /gnu/packages/maths.scm
parent593096355501dfd76c2e92b1fbd87f940ab1d1f2 (diff)
downloadguix-patches-51c55cedda6c69ba68da6be88176b847effa6479.tar
guix-patches-51c55cedda6c69ba68da6be88176b847effa6479.tar.gz
gnu: netcdf-parallel-openmpi: Allow MPI tests to pass.
* gnu/packages/maths.scm (netcdf-parallel-openmpi)[arguments]: Add 'mip-setup' phase.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 20582c33da..d83ea6741a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1607,7 +1607,11 @@ sharing of scientific data.")
"--enable-parallel-tests"
;; Shared libraries not supported with parallel IO.
"--disable-shared" "--with-pic"
- ,flags))))))
+ ,flags))
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-after 'build 'mpi-setup
+ ,%openmpi-setup)))))))
(define-public netcdf-fortran
(package