summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-01-01 15:36:12 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-01 15:36:12 +0100
commit4cd0b37f6b32a431e2144050b491477fbf1835e5 (patch)
treed1d6cdaa867366e4673d3ebf0be57849dfb81952 /gnu/packages/maths.scm
parent1fcb98ca54e882330f3c64dfafe04ad2258d4780 (diff)
downloadguix-patches-4cd0b37f6b32a431e2144050b491477fbf1835e5.tar
guix-patches-4cd0b37f6b32a431e2144050b491477fbf1835e5.tar.gz
gnu: gsl: Add 'tunable?' property.
* gnu/packages/maths.scm (gsl)[properties]: New field.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index efc64a7c48..b0944f307b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2018, 2020, 2021 Kei Kebreau <kkebreau@posteo.net>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018, 2019, 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
@@ -579,6 +579,10 @@ and C++. It includes a wide range of mathematical routines, with over 1000
functions in total. Subject areas covered by the library include:
differential equations, linear algebra, Fast Fourier Transforms and random
numbers.")
+
+ ;; Linear algebra routines should benefit from SIMD optimizations.
+ (properties `((tunable? . #t)))
+
(license license:gpl3+)))
;; TODO: Merge back into the gsl package as a separate output.