summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-08-25 15:18:56 +0200
committerLudovic Courtès <ludo@gnu.org>2020-08-26 00:51:56 +0200
commit4788e5542025ba82e03e02d49a04416292d1fccb (patch)
treeeb4a42c7ff8f35503d669ad3a498e65e8323f390 /gnu/packages/maths.scm
parent8d0e5c2655b17abaf36dbd64491e6b039fb46b49 (diff)
downloadguix-patches-4788e5542025ba82e03e02d49a04416292d1fccb.tar
guix-patches-4788e5542025ba82e03e02d49a04416292d1fccb.tar.gz
gnu: hdf5: Use 'package/inherit' for variants.
* gnu/packages/maths.scm (hdf5-1.10, hdf5-parallel-openmpi): Use 'package/inherit'.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 64b684100d..8e0d30742a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1181,23 +1181,23 @@ extremely large and complex data collections.")
"https://www.hdfgroup.org/ftp/HDF5/current/src/unpacked/COPYING"))))
(define-public hdf5-1.10
- (package (inherit hdf5-1.8)
+ (package/inherit hdf5-1.8
(version "1.10.6")
(source
(origin
- (method url-fetch)
- (uri (list (string-append "https://support.hdfgroup.org/ftp/HDF5/releases/"
- "hdf5-" (version-major+minor version)
- "/hdf5-" version "/src/hdf5-"
- version ".tar.bz2")
- (string-append "https://support.hdfgroup.org/ftp/HDF5/"
- "current"
- (apply string-append
- (take (string-split version #\.) 2))
- "/src/hdf5-" version ".tar.bz2")))
- (sha256
- (base32 "1gf38x51128hn00744358w27xgzjk0ff4wra4yxh2lk804ck1mh9"))
- (patches (search-patches "hdf5-config-date.patch"))))))
+ (method url-fetch)
+ (uri (list (string-append "https://support.hdfgroup.org/ftp/HDF5/releases/"
+ "hdf5-" (version-major+minor version)
+ "/hdf5-" version "/src/hdf5-"
+ version ".tar.bz2")
+ (string-append "https://support.hdfgroup.org/ftp/HDF5/"
+ "current"
+ (apply string-append
+ (take (string-split version #\.) 2))
+ "/src/hdf5-" version ".tar.bz2")))
+ (sha256
+ (base32 "1gf38x51128hn00744358w27xgzjk0ff4wra4yxh2lk804ck1mh9"))
+ (patches (search-patches "hdf5-config-date.patch"))))))
(define-public hdf5
;; Default version of HDF5.
@@ -1411,7 +1411,7 @@ Swath).")
(license (license:non-copyleft home-page))))
(define-public hdf5-parallel-openmpi
- (package (inherit hdf5)
+ (package/inherit hdf5
(name "hdf5-parallel-openmpi")
(inputs
`(("mpi" ,openmpi)