summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-12-18 13:36:50 +0000
committerLudovic Courtès <ludo@gnu.org>2022-01-20 15:28:13 +0100
commit3bfcc63c310e022e806a101e3f67aa87ba709409 (patch)
treeeb549b9bff15b2e23179d331370e5f391968c958 /gnu/packages/maths.scm
parent6b36def51c587d58127b5868cc336dd01e77fa59 (diff)
downloadguix-patches-3bfcc63c310e022e806a101e3f67aa87ba709409.tar
guix-patches-3bfcc63c310e022e806a101e3f67aa87ba709409.tar.gz
gnu: dune-common: Update to 2.7.1.
* gnu/packages/maths.scm (dune-common): Update to 2.7.1. [arguments]: Parallelize build-tests phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 13a917e0fd..b7497e7050 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6362,7 +6362,7 @@ linear algebra primitives specifically targeting graph analytics.")
(define-public dune-common
(package
(name "dune-common")
- (version "2.7.0")
+ (version "2.7.1")
(source
(origin
(method url-fetch)
@@ -6370,14 +6370,18 @@ linear algebra primitives specifically targeting graph analytics.")
version "/dune-common-" version ".tar.gz"))
(sha256
(base32
- "140q1zh44cr5yrjwg4b5ga803rkqv55vk30l2cqm29aklj1wb0rw"))))
+ "0sidwdkyrrqjkqhpvrlc991pzi5xzlvxk91s2n7qk3widwy7fch2"))))
(build-system cmake-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'build 'build-tests
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "build_tests" make-flags))))))
+ (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+ (apply invoke "make" "build_tests"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))))
(inputs
(list gmp metis openblas python superlu))
(native-inputs