summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRobert Smith <robertsmith@posteo.net>2019-11-16 16:18:43 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-19 17:27:58 +0100
commit3b7828cc7f938fcb369976cbe75d9c85f22583a1 (patch)
tree4814e0497cec93b82f6fa2c23d2d87cd20a63733 /gnu/packages/maths.scm
parent5dea5cbc62547f50a793ce905cdd4d1a62be60e1 (diff)
downloadguix-patches-3b7828cc7f938fcb369976cbe75d9c85f22583a1.tar
guix-patches-3b7828cc7f938fcb369976cbe75d9c85f22583a1.tar.gz
gnu: Add minisat.
* gnu/packages/patches/minisat-friend-declaration.patch: New file. * gnu/packages/patches/minisat-install.patch: New file. * gnu/local.mk (dist_patch_DATA): Add both files above. * gnu/packages/maths.scm (minisat): New exported variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 16a9d97a47..32608ea2ff 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2018 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
+;;; Copyright © 2019 Robert Smith <robertsmith@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5242,3 +5243,42 @@ fields of knowledge.")
(home-page "http://speedcrunch.org/")
(license license:gpl2+)))
+(define-public minisat
+ ;; This is the last commit which is available upstream, no
+ ;; release happened since 2010.
+ (let ((commit "37dc6c67e2af26379d88ce349eb9c4c6160e8543")
+ (revision "1"))
+ (package
+ (name "minisat")
+ (version (string-append "2.2.0-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/niklasso/minisat.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "091hf3qkm197s5r7xcr3m07xsdwyz2rqk1hc9kj0hn13imz09irq"))
+ (patches
+ (search-patches "minisat-friend-declaration.patch"
+ "minisat-install.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list (string-append "prefix=" %output))
+ #:tests? #f ;no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("zlib:static" ,zlib "static")
+ ("zlib" ,zlib)))
+ (synopsis
+ "Small, yet efficient, SAT solver")
+ (description
+ "MiniSat is a minimalistic, open-source SAT solver, developed to help
+researchers and developers alike to get started on SAT.")
+ (home-page
+ "http://minisat.se/MiniSat.html")
+ (license license:expat))))