summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-01-27 16:06:13 -0500
committerKei Kebreau <kkebreau@posteo.net>2018-03-31 14:05:25 -0400
commit36ce25f0924c093766e344b2102d3e7f9ca1b6f2 (patch)
tree2ccb6010cd7158e2eee921b707d22b731ad53379 /gnu/packages/maths.scm
parentab5f3f21313799fe64ac8ebffde098bde7ceaa3e (diff)
downloadguix-patches-36ce25f0924c093766e344b2102d3e7f9ca1b6f2.tar
guix-patches-36ce25f0924c093766e344b2102d3e7f9ca1b6f2.tar.gz
gnu: Add qtoctave.
* gnu/packages/maths.scm (qtoctave): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4699f2511c..8db4a5594b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1387,6 +1387,31 @@ Work may be performed both at the interactive command-line as well as via
script files.")
(license license:gpl3+)))
+(define-public qtoctave
+ (package (inherit octave)
+ (name "qtoctave")
+ (inputs
+ `(("qscintilla" ,qscintilla)
+ ("qt" ,qtbase)
+ ,@(package-inputs octave)))
+ (native-inputs
+ `(("qttools" , qttools) ;for lrelease
+ ,@(package-native-inputs octave)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments octave)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'configure 'patch-qscintilla-library-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The QScintilla library that the Octave configure script tries
+ ;; to link with should be named libqscintilla-qt5.so, but the
+ ;; QScintilla input provides the shared library as
+ ;; libqscintilla2_qt5.so.
+ (substitute* "configure"
+ (("qscintilla2-qt5")
+ "qscintilla2_qt5"))
+ #t))))))))
+
(define-public opencascade-oce
(package
(name "opencascade-oce")