summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-07-25 15:12:16 +0000
committerLudovic Courtès <ludo@gnu.org>2022-08-01 17:20:26 +0200
commit32bcadc98c146d373db20c4154cd0acfb12de6e1 (patch)
tree7caa27c7057840cf9b6ef6ca4880a96e8d1b493e /gnu/packages/maths.scm
parenta42730183a6eeb381c4251890586848bedbac79a (diff)
downloadguix-patches-32bcadc98c146d373db20c4154cd0acfb12de6e1.tar
guix-patches-32bcadc98c146d373db20c4154cd0acfb12de6e1.tar.gz
gnu: trilinos-for-dealii-openmpi: Remove input labels.
* gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[native-inputs, inputs, propagated-inputs]: Remove labels. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm53
1 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 99b5e36ff6..e3cc3c993e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5152,34 +5152,35 @@ revised simplex and the branch-and-bound methods.")
(base32 "0fnwlhzsh85qj38cq3igbs8nm1b2jdgr2z734sapmyyzsy21mkgp"))))
(build-system cmake-build-system)
(native-inputs
- `(;; The build fails with the current gcc.
- ;; Use the version from when Trilinos was added.
- ("gcc" ,gcc-7)
- ("gfortran" ,gfortran)
- ;; Trilinos's repository contains several C-shell scripts, but adding
- ;; tcsh to the native inputs does not result in the check phase running
- ;; any more tests than without it (nor is tcsh required to build
- ;; Trilinos).
- ;; It seems that Trilinos has replaced its use of C-shell test scripts
- ;; with CMake's testing facilities.
- ;; For example,
- ;; packages/zoltan/doc/Zoltan_html/dev_html/dev_test_script.html [1]
- ;; states that Zoltan's C-shell test script
- ;; packages/zoltan/test/test_zoltan has been obsoleted by the tests now
- ;; performed through CMake.
- ;;
- ;; Perl is required for some Zoltan tests and Python 2 for one ML test.
- ;;
- ;; [1]: https://cs.sandia.gov/zoltan/dev_html/dev_test_script.html
- ("perl" ,perl)
- ("python" ,python-2)))
+ (list
+ ;; The build fails with the current gcc.
+ ;; Use the version from when Trilinos was added.
+ gcc-7
+ gfortran
+ ;; Trilinos's repository contains several C-shell scripts, but adding
+ ;; tcsh to the native inputs does not result in the check phase running
+ ;; any more tests than without it (nor is tcsh required to build
+ ;; Trilinos).
+ ;; It seems that Trilinos has replaced its use of C-shell test scripts
+ ;; with CMake's testing facilities.
+ ;; For example,
+ ;; packages/zoltan/doc/Zoltan_html/dev_html/dev_test_script.html [1]
+ ;; states that Zoltan's C-shell test script
+ ;; packages/zoltan/test/test_zoltan has been obsoleted by the tests now
+ ;; performed through CMake.
+ ;;
+ ;; Perl is required for some Zoltan tests and Python 2 for one ML test.
+ ;;
+ ;; [1]: https://cs.sandia.gov/zoltan/dev_html/dev_test_script.html
+ perl
+ python-2))
(inputs
- `(("blas" ,openblas)
- ("lapack" ,lapack)
- ("mumps" ,mumps-openmpi)
- ("scalapack" ,scalapack)))
+ (list openblas
+ lapack
+ mumps-openmpi
+ scalapack))
(propagated-inputs
- `(("mpi" ,openmpi)))
+ (list openmpi))
(arguments
`(#:build-type "Release"
#:configure-flags