summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-03-04 09:16:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-03-05 08:01:15 +0100
commit279663efa57c0f02805f79408f6fe3aeca7ba1de (patch)
treec5cb5b1327df5cd2901425aa28ea8b629e7cf6bd /gnu/packages/maths.scm
parentd9d9d4861c3ec35c9da442d775f10b6d3013fdeb (diff)
downloadguix-patches-279663efa57c0f02805f79408f6fe3aeca7ba1de.tar
guix-patches-279663efa57c0f02805f79408f6fe3aeca7ba1de.tar.gz
gnu: Add muparser.
* gnu/packages/maths.scm (muparser): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 44f6153011..231206ce30 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -29,6 +29,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix svn-download)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
@@ -965,6 +966,31 @@ point numbers")
;; GPLv2 only is therefore the smallest subset.
(license license:gpl2)))
+(define-public muparser
+ (package
+ (name "muparser")
+ (version "2.2.5")
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url "http://muparser.googlecode.com/svn/trunk/")
+ (revision 34)))
+ (sha256
+ (base32
+ "1d6bdbhx9zj3srwj3m7c9hvr18gnx1fx43h6d25my7q85gicpcwn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--enable-samples=no")
+ #:tests? #f)) ;no "check" target
+ (home-page "http://muparser.beltoforion.de/")
+ (synopsis "Fast parser library for mathematical expressions")
+ (description
+ "muParser is an extensible high performance math parser library. It is
+based on transforming an expression into a bytecode and precalculating
+constant parts of it.")
+ (license license:expat)))
+
(define-public atlas
(package
(name "atlas")