summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-04 09:46:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-02-01 10:44:53 +0200
commit264162124f814470e06e419ea464b6c6bb9b0a3d (patch)
treed5042bddfb6693adfc9231f70dbf8df00ad806d3 /gnu/packages/maths.scm
parentc1043fd60d273c61c80ecfd31fa3a4ea1b24639a (diff)
downloadguix-patches-264162124f814470e06e419ea464b6c6bb9b0a3d.tar
guix-patches-264162124f814470e06e419ea464b6c6bb9b0a3d.tar.gz
gnu: openblas: Fix building on riscv64-linux.
* gnu/packages/maths.scm (openblas)[arguments]: Adjust make-flags on riscv64-linux to target the correct architecture when building for riscv64-linux.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9f7c0476ca..588b7b49d2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4554,6 +4554,8 @@ parts of it.")
;; Failed to detect CPU.
((string-prefix? "armhf" system)
'("TARGET=ARMV7"))
+ ((string-prefix? "riscv64" system)
+ '("TARGET=RISCV64_GENERIC"))
(else '()))))
;; no configure script
#:phases