summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-10-05 15:58:01 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-08 12:26:56 +0200
commit229e04c66e3dfb83195552bb6a72496bf0493293 (patch)
tree5334d98669e189ec81a3fcac0ef1a72a79e2c5e5 /gnu/packages/maths.scm
parent31113b6f3327704fcfed1e00717c131f9c0a6e2c (diff)
downloadguix-patches-229e04c66e3dfb83195552bb6a72496bf0493293.tar
guix-patches-229e04c66e3dfb83195552bb6a72496bf0493293.tar.gz
gnu: gmsh: Update to 4.6.0.
Gmsh bundles METIS 5 released with Apache License 2.0 since upstream commit eaff7f6477fe876991615cfa4b5832bd5f12994b. Instead, Gmsh is linked with the package 'metis'. * gnu/packages/maths.scm (gmsh): Update to 4.6.0. (propagated-inputs): Replace 'opencascade-oce' by 'opencascade-occt', add 'metis'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 232ef40b9c..2a909ec1d4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2156,7 +2157,7 @@ This is the certified version of the Open Cascade Technology (OCCT) library.")
(define-public gmsh
(package
(name "gmsh")
- (version "2.16.0")
+ (version "4.6.0")
(source
(origin
(method git-fetch)
@@ -2168,12 +2169,11 @@ This is the certified version of the Open Cascade Technology (OCCT) library.")
version)))))
(file-name (git-file-name name version))
(sha256
- (base32 "08rq4jajwmlpivnm9yifz2jhaivnz065lnk0h2zv773nwl9wf162"))
+ (base32 "0m0pjxcy1bnr7a20i11lh0ih159pphq9wsvfjr3sfx4y3lginz5y"))
(modules '((guix build utils)))
(snippet
- ;; Remove non-free METIS code
'(begin
- (delete-file-recursively "contrib/Metis")
+ (delete-file-recursively "contrib/metis")
#t))))
(build-system cmake-build-system)
(propagated-inputs
@@ -2184,14 +2184,15 @@ This is the certified version of the Open Cascade Technology (OCCT) library.")
("lapack" ,lapack)
("mesa" ,mesa)
("glu" ,glu)
- ("opencascade-oce" ,opencascade-oce)
+ ("metis" ,metis)
+ ("opencascade-occt" ,opencascade-occt)
("libx11" ,libx11)
("libxext" ,libxext)))
(inputs
`(("fontconfig" ,fontconfig)
("libxft" ,libxft)))
(arguments
- `(#:configure-flags `("-DENABLE_METIS:BOOL=OFF"
+ `(#:configure-flags `("-DENABLE_SYSTEM_CONTRIB:BOOL=ON"
"-DENABLE_BUILD_SHARED:BOOL=ON"
"-DENABLE_BUILD_DYNAMIC:BOOL=ON")))
(home-page "http://gmsh.info/")