summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-09 23:14:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-09 23:17:26 +0200
commit1da7f9089f727bb3dce73e4d2acfc2803b82e090 (patch)
tree1b5836f2feaea4e870e12786f9f5b1e2300817bd /gnu/packages/maths.scm
parent1e81140cb568ccf33bfea14b51aee043c6a2ef71 (diff)
downloadguix-patches-1da7f9089f727bb3dce73e4d2acfc2803b82e090.tar
guix-patches-1da7f9089f727bb3dce73e4d2acfc2803b82e090.tar.gz
gnu: Add gsl-static.
* gnu/packages/maths.scm (gsl-static): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 532d4249c9..58bde73a0a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -581,6 +581,15 @@ differential equations, linear algebra, Fast Fourier Transforms and random
numbers.")
(license license:gpl3+)))
+;; TODO: Merge back into the gsl package as a separate output.
+(define-public gsl-static
+ (package/inherit gsl
+ (name "gsl-static")
+ (arguments
+ `(,@(package-arguments gsl)
+ #:configure-flags (list "--disable-shared")
+ #:make-flags (list "CFLAGS=-fPIC")))))
+
(define-public sleef
(package
(name "sleef")