summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-01 11:49:17 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-01 12:06:00 +0200
commit0cf2b6f2dbcd299f7a4b7a563cf34ae5de154b15 (patch)
tree0b653bb411222fda1d159cb05bee722ff8bac9cc /gnu/packages/maths.scm
parent8d564b8b81b98fec9aac2f5f2d3cb0d1f2ea1416 (diff)
parent717b6ba6aa9ac876b2c2df36096e4579b19ee06c (diff)
downloadguix-patches-0cf2b6f2dbcd299f7a4b7a563cf34ae5de154b15.tar
guix-patches-0cf2b6f2dbcd299f7a4b7a563cf34ae5de154b15.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm26
1 files changed, 16 insertions, 10 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ef50dfcded..357382f038 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2017, 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Dave Love <me@fx@gnu.org>
-;;; Copyright © 2018 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2018, 2019 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Nadya Voronova <voronovank@gmail.com>
;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
@@ -3645,7 +3645,7 @@ revised simplex and the branch-and-bound methods.")
(define-public dealii
(package
(name "dealii")
- (version "9.0.1")
+ (version "9.1.1")
(source
(origin
(method url-fetch)
@@ -3653,8 +3653,7 @@ revised simplex and the branch-and-bound methods.")
"download/v" version "/dealii-" version ".tar.gz"))
(sha256
(base32
- "0r7f8rhl3xr94imd372plizdcbqk0a70w73lwc3vw912dxk0sbyz"))
- (patches (search-patches "dealii-mpi-deprecations.patch"))
+ "0xhjv0gzswpjbc43xbrpwfc5848g508l01855nszx3g5gwzlhnzw"))
(modules '((guix build utils)))
(snippet
;; Remove bundled sources: UMFPACK, TBB, muParser, and boost
@@ -4116,7 +4115,7 @@ as equations, scalars, vectors, and matrices.")
(define-public z3
(package
(name "z3")
- (version "4.8.4")
+ (version "4.8.6")
(home-page "https://github.com/Z3Prover/z3")
(source (origin
(method git-fetch)
@@ -4125,7 +4124,7 @@ as equations, scalars, vectors, and matrices.")
(file-name (git-file-name name version))
(sha256
(base32
- "014igqm5vwswz0yhz0cdxsj3a6dh7i79hvhgc3jmmmz3z0xm1gyn"))))
+ "1sywcqj5y8yp28m4cdvzsgw74kd6zr1s3y1x17ky8pr9prvpvl6x"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -4316,7 +4315,7 @@ reduction.")
(define-public mcrl2
(package
(name "mcrl2")
- (version "201707.1.15162")
+ (version "201908.0")
(source (origin
(method url-fetch)
(uri (string-append "http://www.mcrl2.org/download/devel/mcrl2-"
@@ -4324,9 +4323,7 @@ reduction.")
".tar.gz"))
(sha256
(base32
- "1ziww2fchsklm25hl9p2mngssxfh9w07nc114cncqaxfibqp2p8f"))))
- (native-inputs
- `(("subversion" ,subversion)))
+ "1i4xgl2d5fgiz1mwi50cyfkrrcpm8nxfayfjgmhq7chs58wlhfsz"))))
(inputs
`(("boost" ,boost)
("glu" ,glu)
@@ -4344,6 +4341,15 @@ analysed.")
(home-page "https://mcrl2.org")
(license license:boost1.0)))
+(define-public mcrl2-minimal
+ (package
+ (inherit mcrl2)
+ (name "mcrl2-minimal")
+ (inputs
+ `(("boost" ,boost)))
+ (arguments
+ '(#:configure-flags '("-DMCRL2_ENABLE_GUI_TOOLS=OFF")))))
+
(define-public r-subplex
(package
(name "r-subplex")