summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-03 18:32:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-03 18:32:56 +0200
commit0ad05c15e3c198e96f2ded17d22897fb0891f67d (patch)
tree199eaa0e34e4d290842a8df0d4d5aa2d642f4836 /gnu/packages/maths.scm
parentf27b1cf091e31840af9a8251d5035fcb4b26a528 (diff)
downloadguix-patches-0ad05c15e3c198e96f2ded17d22897fb0891f67d.tar
guix-patches-0ad05c15e3c198e96f2ded17d22897fb0891f67d.tar.gz
gnu: GSL: Remove unnecessary (%current-system) call.
* gnu/packages/maths.scm (gsl)[arguments]: Use the let-bound SYSTEM variable instead of %CURRENT-SYSTEM.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 05cea4713c..6d7625cfc1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -399,7 +399,7 @@ semiconductors.")
(substitute* "spmatrix/test.c"
((".*test_complex.*") "\n"))
#t)))))
- ((string-prefix? "i686" (%current-system))
+ ((string-prefix? "i686" system)
;; There are rounding issues with these tests on i686:
;; https://lists.gnu.org/archive/html/bug-gsl/2016-10/msg00000.html
;; https://lists.gnu.org/archive/html/bug-gsl/2020-04/msg00000.html