summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-28 00:38:25 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-28 00:38:25 +0100
commit0897ad7fac04fc9d814e83eed46e88c7bf9740bc (patch)
tree9bccfdb52de4c468778ceaabe337c0539c302a30 /gnu/packages/maths.scm
parent6d460e80d1b06fc094374e7ba5c2503f2a897f11 (diff)
parent9943d238e9f07dccae973b641eb7738637ce95fb (diff)
downloadguix-patches-0897ad7fac04fc9d814e83eed46e88c7bf9740bc.tar
guix-patches-0897ad7fac04fc9d814e83eed46e88c7bf9740bc.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm95
1 files changed, 2 insertions, 93 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9c576ee648..acee64a63f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -62,7 +62,6 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
- #:use-module (guix build-system r)
#:use-module (guix build-system ruby)
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
@@ -2342,45 +2341,6 @@ sparse system of linear equations A x = b using Gaussian elimination.")
(inputs
(alist-delete "pt-scotch" (package-inputs mumps-openmpi)))))
-(define-public r-quadprog
- (package
- (name "r-quadprog")
- (version "1.5-7")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "quadprog" version))
- (sha256
- (base32
- "0vg7i9p241bwvfdspjbydjrsvgipl6nsb8bjigp0hbbgvxbixx0s"))))
- (build-system r-build-system)
- (native-inputs
- `(("gfortran" ,gfortran)))
- (home-page "https://cran.r-project.org/web/packages/quadprog")
- (synopsis "Functions to solve quadratic programming problems")
- (description
- "This package contains routines and documentation for solving quadratic
-programming problems.")
- (license license:gpl3+)))
-
-(define-public r-pracma
- (package
- (name "r-pracma")
- (version "2.2.5")
- (source (origin
- (method url-fetch)
- (uri (cran-uri "pracma" version))
- (sha256
- (base32 "0isd3s0i4mzmva8lkh0j76hwjy1w50q7d1n9lhxsnnkgalx3xs1g"))))
- (build-system r-build-system)
- (home-page "https://cran.r-project.org/web/packages/pracma/")
- (synopsis "Practical numerical math functions")
- (description "This package provides functions for numerical analysis and
-linear algebra, numerical optimization, differential equations, plus some
-special functions. It uses Matlab function names where appropriate to simplify
-porting.")
- (license license:gpl3+)))
-
(define-public ruby-asciimath
(package
(name "ruby-asciimath")
@@ -2992,7 +2952,7 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- (version "19.09.0")
+ (version "19.11.1")
(source
(origin
(method git-fetch)
@@ -3001,7 +2961,7 @@ point numbers.")
(commit (string-append "Version-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "195j6j8z0jd6xg3a63ywbrbsc6dany795m3fb95nbx1vq0bqqvvn"))))
+ (base32 "16xizaddb27432n1083y89ir5zdqvllsgbwrzzk4jc2rw1ldxfsv"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)))
@@ -4368,57 +4328,6 @@ analysed.")
(arguments
'(#:configure-flags '("-DMCRL2_ENABLE_GUI_TOOLS=OFF")))))
-(define-public r-subplex
- (package
- (name "r-subplex")
- (version "1.5-4")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "subplex" version))
- (sha256
- (base32
- "10cbgbx1bgsax5z7gz6716g360xpq4mvq19cf4qqrxv02mmwz57z"))))
- (build-system r-build-system)
- (native-inputs
- `(("gfortran" ,gfortran)))
- (home-page "https://cran.r-project.org/web/packages/subplex")
- (synopsis "Unconstrained optimization using the subplex algorithm")
- (description "This package implements the Subplex optimization algorithm.
-It solves unconstrained optimization problems using a simplex method on
-subspaces. The method is well suited for optimizing objective functions that
-are noisy or are discontinuous at the solution.")
- (license license:gpl3+)))
-
-(define-public r-desolve
- (package
- (name "r-desolve")
- (version "1.24")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "deSolve" version))
- (sha256
- (base32
- "0hkvspq0fp8j64l9zayab2l2nazazhwfgfym0jllh0xv5a12r99s"))))
- (properties `((upstream-name . "deSolve")))
- (build-system r-build-system)
- (native-inputs
- `(("gfortran" ,gfortran)))
- (home-page "https://desolve.r-forge.r-project.org/")
- (synopsis "Solvers for initial value problems of differential equations")
- (description "This package provides functions that solve initial
-value problems of a system of first-order ordinary differential equations (ODE),
-of partial differential equations (PDE), of differential algebraic equations
-(DAE), and of delay differential equations. The functions provide an interface
-to the FORTRAN functions lsoda, lsodar, lsode, lsodes of the ODEPACK collection,
-to the FORTRAN functions dvode and daspk and a C-implementation of solvers of
-the Runge-Kutta family with fixed or variable time steps. The package contains
-routines designed for solving ODEs resulting from 1-D, 2-D and 3-D partial
-differential equations (PDE) that have been converted to ODEs by numerical
-differencing.")
- (license license:gpl2+)))
-
(define-public tcalc
(package
(name "tcalc")