summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-02-24 00:01:21 -0500
committerKei Kebreau <kkebreau@posteo.net>2018-02-24 18:05:52 -0500
commit0181df537ffb4e4273b2ca005738fdb7bd3d73f5 (patch)
treecb09fece3f15488f4348428bc9c7b3b4937a1d08 /gnu/packages/maths.scm
parente8ee100e8eb46224d5549dffc707cfeb96ad0e21 (diff)
downloadguix-patches-0181df537ffb4e4273b2ca005738fdb7bd3d73f5.tar
guix-patches-0181df537ffb4e4273b2ca005738fdb7bd3d73f5.tar.gz
gnu: wxmaxima: Update to 18.02.0.
* gnu/packages/maths.scm (wxmaxima): Update to 18.02.0. [source]: Add patch. [build-system]: Use the cmake-build-system. [native-inputs]: Remove autoconf and automake. [arguments]: Disable tests, remove 'autoconf' phase. * gnu/packages/patches/wxmaxima-do-not-use-old-gnuplot-parameters.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 25e1d5a312..b20cec5440 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2489,7 +2489,7 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- (version "17.10.1")
+ (version "18.02.0")
(source
(origin
(method url-fetch)
@@ -2498,12 +2498,12 @@ point numbers.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0qlzc31cqkwpfgrb9cif9bcnkj3rq487plg4rns7jxv6pq4609v1"))))
- (build-system gnu-build-system)
+ "03kr2rgfp4hcf3is8m8d8f9hj660c3xgrc50vrrfpixx4syh6wvj"))
+ (patches
+ (search-patches "wxmaxima-do-not-use-old-gnuplot-parameters.patch"))))
+ (build-system cmake-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gettext" ,gettext-minimal)))
+ `(("gettext" ,gettext-minimal)))
(inputs
`(("wxwidgets" ,wxwidgets)
("maxima" ,maxima)
@@ -2512,11 +2512,9 @@ point numbers.")
("gtk+" ,gtk+)
("shared-mime-info" ,shared-mime-info)))
(arguments
- `(#:phases
+ `(#:tests? #f ; no check target
+ #:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autoconf
- (lambda _
- (zero? (system* "sh" "bootstrap"))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (string-append (assoc-ref outputs "out")