summaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-08-23 17:18:02 +0000
committerEfraim Flashner <efraim@flashner.co.il>2017-09-12 09:55:37 +0300
commit4d553e0a9374e25f03a4ef2fd2aba783c47e5005 (patch)
treedd9bdedda3223044244b47283db5413124d7cd29 /gnu/packages/mate.scm
parentda78e01b871b7b1971a49d5d40cc4f0af31eb1fa (diff)
downloadguix-patches-4d553e0a9374e25f03a4ef2fd2aba783c47e5005.tar
guix-patches-4d553e0a9374e25f03a4ef2fd2aba783c47e5005.tar.gz
gnu: Add mate-media.
* gnu/packages/mate.scm (mate-media): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 1af6b50e9c..b8b40569b9 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -469,6 +469,43 @@ Interactive Weather Information Network (IWIN).
@end enumerate\n")
(license (list license:gpl2+ license:lgpl2.0+ license:gpl3+))))
+(define-public mate-media
+ (package
+ (name "mate-media")
+ (version "1.18.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1l0j71d07898wb6ily09sj1xczwrmcw13wyhxwns7sxw592nwi04"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("gettext" ,gettext-minimal)
+ ("gobject-introspection" ,gobject-introspection)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
+ ("libmatemixer" ,libmatemixer)
+ ("libxml2" ,libxml2)
+ ("mate-applets" ,mate-applets)
+ ("mate-desktop" ,mate-desktop)
+ ("mate-panel" ,mate-panel)
+ ("pango" ,pango)
+ ("startup-notification" ,startup-notification)))
+ (home-page "https://mate-desktop.org/")
+ (synopsis "Multimedia related programs for the MATE desktop")
+ (description
+ "Mate-media includes the MATE media tools for MATE, including
+mate-volume-control, a MATE volume control application and applet.")
+ (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.1+))))
+
(define-public mate-panel
(package
(name "mate-panel")