summaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-24 15:28:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-24 20:50:44 +0200
commit2aab587f842908a886e3bd08b028885dddd650e0 (patch)
tree87c0723a9ae2c69ab6920d90b6e87ad8510492fe /gnu/packages/mate.scm
parent5664bcdcb0e4c10dfe48dd5e4730fc3c746a21e2 (diff)
parent65c46e79e0495fe4d32f6f2725d7233fff10fd70 (diff)
downloadguix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar
guix-patches-2aab587f842908a886e3bd08b028885dddd650e0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 8360be0197..c90ce81baa 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -176,6 +176,8 @@ actions.")
(setenv "CONFIG_SHELL" (which "sh"))
(invoke "sh" "autogen.sh"))))))
(native-inputs
+ ;; autoconf-wrapper is required due to the non-standard
+ ;; 'autoconf phase.
`(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("intltool" ,intltool)
@@ -679,6 +681,7 @@ mate-volume-control, a MATE volume control application and applet.")
`(("dconf" ,dconf)
("cairo" ,cairo)
("dbus-glib" ,dbus-glib)
+ ("gtk-layer-shell" ,gtk-layer-shell)
("gtk+" ,gtk+)
("libcanberra" ,libcanberra)
("libice" ,libice)
@@ -693,7 +696,8 @@ mate-volume-control, a MATE volume control application and applet.")
("mate-desktop" ,mate-desktop)
("mate-menus" ,mate-menus)
("pango" ,pango)
- ("tzdata" ,tzdata)))
+ ("tzdata" ,tzdata)
+ ("wayland" ,wayland)))
(home-page "https://mate-desktop.org/")
(synopsis "Panel for MATE")
(description
@@ -1202,7 +1206,7 @@ Re-decorates windows on un-maximise.
(("dbus-1") ""))))))))
(native-inputs
`(("automake" ,automake)
- ("autoconf" ,autoconf-wrapper)
+ ("autoconf" ,autoconf)
("gettext" ,gettext-minimal)
("intltool" ,intltool)
("mate-common" ,mate-common)