summaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-12-30 22:51:27 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-30 22:55:25 +0100
commit1da3338c3e1456223b81745b9695f2cb09a0f045 (patch)
tree12736e2276250873f086781d9c43f23d486d5ad7 /gnu/packages/mate.scm
parenta1eef8257eb20fcba17266512201ecef1877ad0e (diff)
downloadguix-patches-1da3338c3e1456223b81745b9695f2cb09a0f045.tar
guix-patches-1da3338c3e1456223b81745b9695f2cb09a0f045.tar.gz
gnu: Add mate-system-monitor.
* gnu/packages/mate.scm (mate-system-monitor): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 820dcb8e42..c6c2aa1c01 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -1443,6 +1443,47 @@ can be used as backgrounds in the MATE Desktop environment.")
"Pluma is the text editor for the MATE Desktop.")
(license license:gpl2)))
+(define-public mate-system-monitor
+ (package
+ (name "mate-system-monitor")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1wcvrl4lfnjkhywb311p29prf1qiab6iynb6q1fgfsl6za8hsz48"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("gettext" ,gettext-minimal)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("yelp-tools" ,yelp-tools)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("glib" ,glib)
+ ("glibmm" ,glibmm)
+ ("gtkmm" ,gtkmm)
+ ("gtk+" ,gtk+)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("libsigc++" ,libsigc++)
+ ("libcanberra" ,libcanberra)
+ ("libxml2" ,libxml2)
+ ("libwnck" ,libwnck)
+ ("libgtop" ,libgtop)
+ ("librsvg" ,librsvg)
+ ("polkit" ,polkit)))
+ (home-page "https://mate-desktop.org/")
+ (synopsis "System Monitor for MATE")
+ (description
+ "Mate System Monitor provides a tool for for the
+MATE Desktop to monitor your system resources and usage.")
+ (license license:gpl2)))
+
(define-public mate
(package
(name "mate")