summaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-12-30 22:44:07 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-30 22:55:23 +0100
commit033a2ac6917e26c5555c57acd6564fed5f263dfc (patch)
tree4da371c8ef4f08c90b4789a0919ec8887ee9666d /gnu/packages/mate.scm
parent694285712ebd4967b202ac1a8a7ffac7b76e29f1 (diff)
downloadguix-patches-033a2ac6917e26c5555c57acd6564fed5f263dfc.tar
guix-patches-033a2ac6917e26c5555c57acd6564fed5f263dfc.tar.gz
gnu: Add mate-calc.
* gnu/packages/mate.scm (mate-calc): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index f25eb8dd92..484fd373d5 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -995,6 +995,38 @@ general use of the MATE Desktop environment. Topics covered include
sessions, panels, menus, file management, and preferences.")
(license (list license:fdl1.1+ license:gpl2+))))
+(define-public mate-calc
+ (package
+ (name "mate-calc")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0qfs6kx2nymbn6j3mnzgvk8p54ghc78jslsf4wjqsdq021qyl0ly"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("yelp-tools" ,yelp-tools)))
+ (inputs
+ `(("atk" ,atk)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("libxml2" ,libxml2)
+ ("libcanberra" ,libcanberra)
+ ("pango" ,pango)))
+ (home-page "https://mate-desktop.org/")
+ (synopsis "Calculator for MATE")
+ (description
+ "Mate Calc is the GTK+ calculator application for the MATE Desktop.")
+ (license license:gpl2+)))
+
(define-public mate
(package
(name "mate")