summaryrefslogtreecommitdiff
path: root/gnu/packages/mastodon.scm
diff options
context:
space:
mode:
authorTaiju HIGASHI <higashi@taiju.info>2021-12-28 14:03:17 +0900
committerLudovic Courtès <ludo@gnu.org>2022-01-05 23:44:18 +0100
commitb0d25a711816d039ba9ec0febc956e7bdf270178 (patch)
treec99634b80d9086409ddfb03af00bc98937b74cb4 /gnu/packages/mastodon.scm
parentbfdeba11f86b18172194b416c6eb59b7cc7ef355 (diff)
downloadguix-patches-b0d25a711816d039ba9ec0febc956e7bdf270178.tar
guix-patches-b0d25a711816d039ba9ec0febc956e7bdf270178.tar.gz
gnu: tootle: Fix build.
* gnu/packages/patches/tootle-glib-object-naming.patch, gnu/packages/patches/tootle-reason-phrase.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/mastodon.scm (tootle)[source]: Use them. [inputs]: Use LIBSOUP-MINIMAL-2 instead of LIBSOUP. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mastodon.scm')
-rw-r--r--gnu/packages/mastodon.scm28
1 files changed, 18 insertions, 10 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index 8a8e2e7786..d1efc55c9f 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages)
#:use-module (gnu packages check)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
@@ -79,15 +81,21 @@ Features include:
(name "tootle")
(version "1.0")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bleakgrey/tootle")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1nm57239mhdq462an6bnhdlijpijxmjs9mqbyirwxwa048d3n4rm"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bleakgrey/tootle")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nm57239mhdq462an6bnhdlijpijxmjs9mqbyirwxwa048d3n4rm"))
+ (patches
+ (search-patches
+ ;; https://github.com/bleakgrey/tootle/pull/339
+ "tootle-glib-object-naming.patch"
+ ;; https://github.com/bleakgrey/tootle/pull/322
+ "tootle-reason-phrase.patch"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -125,7 +133,7 @@ Features include:
json-glib
libgee
libhandy
- libsoup
+ libsoup-minimal-2
vala
xdg-utils))
(home-page "https://github.com/bleakgrey/tootle")