summaryrefslogtreecommitdiff
path: root/gnu/packages/mastodon.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-01-05 23:10:36 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-05 23:44:18 +0100
commit282197b52158764889bcc56955dc98940947d493 (patch)
treece6c98de87a0e082378391b28b1ef8d5f6f1c6fd /gnu/packages/mastodon.scm
parentf2d304ac98738ebea8ddb584890cc6fe46f393fc (diff)
downloadguix-patches-282197b52158764889bcc56955dc98940947d493.tar
guix-patches-282197b52158764889bcc56955dc98940947d493.tar.gz
gnu: tootle: Remove trailing #t in phases.
* gnu/packages/mastodon.scm (tootle)[arguments]: Remove trailing #t.
Diffstat (limited to 'gnu/packages/mastodon.scm')
-rw-r--r--gnu/packages/mastodon.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index a50ed7fdf9..d6fd1db2b6 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -105,8 +105,7 @@ Features include:
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "meson/post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t))
+ (("gtk-update-icon-cache") "true"))))
(add-after 'unpack 'patch-source
(lambda _
(substitute* "src/Dialogs/NewAccount.vala"
@@ -115,13 +114,12 @@ Features include:
(substitute* "src/Build.vala"
(("(os_name = ).*" _ first) (string-append first "\"GNU\";\n"))
(("(os_ver = ).*" _ first) (string-append first "\"Guix\";\n"))
- (("GLib.Environment.get_os_info.*") "\"unknown\";\n"))
- #t))
+ (("GLib.Environment.get_os_info.*") "\"unknown\";\n"))))
(add-after 'install 'symlink-package
(lambda* (#:key outputs #:allow-other-keys)
(symlink "com.github.bleakgrey.tootle"
- (string-append (assoc-ref outputs "out") "/bin/tootle"))
- #t)))))
+ (string-append (assoc-ref outputs "out")
+ "/bin/tootle")))))))
(native-inputs
(list gettext-minimal
`(,glib "bin") ; for glib-compile-resources